HDU3764(Cyclic Nacklace)

Cyclic Nacklace

Problem Description

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of “HDU CakeMan”, he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl’s fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls’ lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet’s cycle is 9 and its cyclic count is 2:


在这里插入图片描述
Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by ‘a’ ~‘z’ characters. The length of the string Len: ( 3 <= Len <= 100000 ).

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

Sample Input

3
aaa
abca
abcde

Sample Output

0
2
5

思路

题目说了一堆的废话,大概意思就是给定一个字符串,问至少加入多少个字符可以使得这个字符串变成一个由k个重复子串组成的字符串(k > 1)。样例一不需要加入因为可以由3个a组成输出0,样例二加入b和c字符即可满足要求输出2,样例三加入abcde一组字符串输出5。

针对KMP算法的next数组做一个小小的加强深刻理解next数组的含义,个人认为KMP算法的真正用途不在於单模匹配(Sunday和BM做单模匹配性能更优),而next数组才是精髓。当匹配失败时回到next[j]的位置,也就是说将j的下标位向右移动了j - next[j]位,也就是说这j - next[j]个字符是一组重复的字符串。利用这一性能可以找到一个字符串的最小循环节长度(j - next[j])同理也可以找到循环节个数。

  1. 最小循环节长度是len - next[len];
  2. 完整的循环节的个数是 len / (len - next[len])
  3. 剩余不够一个循环节补全需要的字符个数 (len - next[len]) - len % (len - next[len])
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn = 1e5+1e2;
char s[maxn];
int p[maxn];
void get_next(int len)
{
	memset(p,-1,sizeof(p));
	int i = -1,j = 0;
	while(j < len){		//最好是多算一位,多算一位不影响做匹配但是做Next数组拓展好用
		if(i == -1 || s[i] == s[j]){
			i++;j++;
			p[j] = i;
		}
		else{
			i = p[i];
		}
	}
}
int main()
{
	int n;
	cin>>n;
	while(n--){
		scanf("%s",s);	
		int len = strlen(s);
		get_next(len);
		int res = len - p[len];
		if(len % res == 0 && p[len] != 0){			//循环节个数至少是两个。
			cout<<0<<endl;
		}
		else{
			cout<<res - (len%res)<<endl;
		}
	}
	return 0;
}

愿你走出半生,归来仍是少年~

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章