HDU2594(Simpsons’ Hidden Talents)

Simpsons’ Hidden Talents

Problem Description

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.

Sample Input

clinton
homer
riemann
marjorie

Sample Output

0
rie 3

思路

題目說了一堆的廢話,簡單點說就是求s串的前綴和p串的後綴最大的公共長度。如果不存在輸出0,如果存在輸出公共字符串,並且輸出長度。考慮到KMP算法next數組預處理就是求最大公共前後綴,所以將s串和p串連接起來,但是要注意將二者加一個分隔符有可能會因爲連接的原因導致公共前後綴變長。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <string>
using namespace std;
char s[100005];
char t[50005];
int  p[100005];
void get_next(int slen)
{
	memset(p,-1,sizeof(p));
	int i = 0,j = -1;
	while(i < slen){
		if(j == -1 || s[i] == s[j]){
			i++;j++;
			p[i] = j;
		}
		else{
			j = p[j];
		}
	}
}
int main()
{
	while(~scanf("%s",s)){
		scanf("%s",t);
		int slen = strlen(s);
		s[slen] = '#';s[slen+1] = '\0';		//加入一個無關字符防止最長公共前後綴增長。
		strcat(s,t);
		slen = strlen(s);
		get_next(slen);
		int n = p[slen];
		if(!n){
			printf("0\n");
		}
		else{
			for(int i = 0;i < n;i++){
				printf("%c",s[i]);
			}
			printf(" %d\n",n); 
		}
	}	
	return 0;
}

願你走出半生,歸來仍是少年~

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章