HDU1298(T9)

T9

Problem Description

A while ago it was quite cumbersome to create a message for the Short Message Service (SMS) on a mobile phone. This was because you only have nine keys and the alphabet has more than nine letters, so most characters could only be entered by pressing one key several times. For example, if you wanted to type “hello” you had to press key 4 twice, key 3 twice, key 5 three times, again key 5 three times, and finally key 6 three times. This procedure is very tedious and keeps many people from using the Short Message Service.

This led manufacturers of mobile phones to try and find an easier way to enter text on a mobile phone. The solution they developed is called T9 text input. The “9” in the name means that you can enter almost arbitrary words with just nine keys and without pressing them more than once per character. The idea of the solution is that you simply start typing the keys without repetition, and the software uses a built-in dictionary to look for the “most probable” word matching the input. For example, to enter “hello” you simply press keys 4, 3, 5, 5, and 6 once. Of course, this could also be the input for the word “gdjjm”, but since this is no sensible English word, it can safely be ignored. By ruling out all other “improbable” solutions and only taking proper English words into account, this method can speed up writing of short messages considerably. Of course, if the word is not in the dictionary (like a name) then it has to be typed in manually using key repetition again.

在这里插入图片描述
Figure 8: The Number-keys of a mobile phone.

More precisely, with every character typed, the phone will show the most probable combination of characters it has found up to that point. Let us assume that the phone knows about the words “idea” and “hello”, with “idea” occurring more often. Pressing the keys 4, 3, 5, 5, and 6, one after the other, the phone offers you “i”, “id”, then switches to “hel”, “hell”, and finally shows “hello”.

Write an implementation of the T9 text input which offers the most probable character combination after every keystroke. The probability of a character combination is defined to be the sum of the probabilities of all words in the dictionary that begin with this character combination. For example, if the dictionary contains three words “hell”, “hello”, and “hellfire”, the probability of the character combination “hell” is the sum of the probabilities of these words. If some combinations have the same probability, your program is to select the first one in alphabetic order. The user should also be able to type the beginning of words. For example, if the word “hello” is in the dictionary, the user can also enter the word “he” by pressing the keys 4 and 3 even if this word is not listed in the dictionary.

Input

The first line contains the number of scenarios.Each scenario begins with a line containing the number w of distinct words in the dictionary (0<=w<=1000). These words are given in the next w lines. (They are not guaranteed in ascending alphabetic order, although it’s a dictionary.) Every line starts with the word which is a sequence of lowercase letters from the alphabet without whitespace, followed by a space and an integer p, 1<=p<=100, representing the probability of that word. No word will contain more than 100 letters.

Following the dictionary, there is a line containing a single integer m. Next follow m lines, each consisting of a sequence of at most 100 decimal digits 2-9, followed by a single 1 meaning “next word”.

Output

The output for each scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1.

For every number sequence s of the scenario, print one line for every keystroke stored in s, except for the 1 at the end. In this line, print the most probable word prefix defined by the probabilities in the dictionary and the T9 selection rules explained above. Whenever none of the words in the dictionary match the given number sequence, print “MANUALLY” instead of a prefix.

Terminate the output for every number sequence with a blank line, and print an additional blank line at the end of every scenario.

Sample Input

2
5
hell 3
hello 4
idea 8
next 8
super 3
2
435561
43321
7
another 5
contest 6
follow 3
give 13
integer 6
new 14
program 4
5
77647261
6391
4681
26684371
77771

Sample Output

Scenario #1:
i
id
hel
hell
hello

i
id
ide
idea

Scenario #2:
p
pr
pro
prog
progr
progra
program

n
ne
new

g
in
int

c
co
con
cont
anoth
anothe
another

p
pr
MANUALLY
MANUALLY

思路

题目说了一大堆大概就是小时候用的按键手机怎么快速输出自己想要的字,根据每个字出现的频率决定。先统计每个前缀出现的频率,然后查找的时候从头开始枚举输入的按键。然后对每一次枚举进行dfs深搜刚好就能出现一个又一个的长度不同的字符串。一开始就想一步登天怎么找到想要的答案导致自己迟迟想不到一个完美的方法,然后尝试一步一个脚印每次都增加枚举长度竟然过了。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <vector>
using namespace std;
const int maxn = 100005;
int trie[maxn][26];
int num[maxn];
char p[105];
char ss[105];
char word[105];
char str[10][6] = {"","","abc","def","ghi","jkl",
"mno","pqrs","tuv","wxyz"};			//方便索引 
int cnt,ans;
void insert_s(char *s,int m)
{
	int n = strlen(s);
	int root = 0;
	for(int i = 0;i < n;i++){
		int k = s[i] - 'a';
		if(!trie[root][k]){
			trie[root][k] = ++cnt;
		}
		root = trie[root][k];
		num[root] += m;				//统计前缀出现的频率 
	}
}
void find_s(int st,int ed,int res,int root)
{
	if(st == ed){			
		if(res > ans){
			ans = res;
			ss[ed] = '\0';
			strcpy(word,ss);
		}
		return ;
	}
	int i = p[st] - '0';
	int slen = strlen(str[i]);
	for(int j = 0;j < slen;j++){
		int k = str[i][j] - 'a';
		if(trie[root][k]){			//有这个字母
			ss[st] = str[i][j];
			find_s(st+1,ed,num[trie[root][k]],trie[root][k]);
		}
	}
}
int main()
{
	int t,n,m,q;
	scanf("%d",&t);
	for(int k = 1;k <= t;k++){
		memset(trie,0,sizeof(num));
		memset(num,0,sizeof(num));
		cnt = 0; 
		scanf("%d",&n);
		char s[105];
		for(int i = 0;i < n;i++){
			scanf("%s%d",s,&m);
			insert_s(s,m);
		}
		printf("Scenario #%d:\n",k);
		scanf("%d",&q);
		while(q--){
			scanf("%s",s);
			for(int i = 0;s[i] != '1';i++){
				p[i] = s[i];p[i+1] = '\0';
				ans = 0;find_s(0,i+1,0,0);		
				if(ans == 0){
					printf("MANUALLY\n");
				}
				else{
					printf("%s\n",word);
				}
			}
			printf("\n");
		}
		printf("\n");
	}
	return 0;
}

愿你走出半生,归来仍是少年~

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章