HDU1711(Number Sequence)

Number Sequence

Problem Description

Given two sequences of numbers : a[1], a[2], … , a[N], and b[1], b[2], … , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], … , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], … , a[N]. The third line contains M integers which indicate b[1], b[2], … , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

思路

KMP入門題第一題,直接做KMP匹配就好,最後返回的位置別忘記+1。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 1000005;
int s[maxn],p[10005];
int num[10005];
void get_next(int len)
{
	memset(num,-1,sizeof(num));
	int i = 0,j = -1;
	while(i < len){
		if(j == -1 || p[i] == p[j]){
			i++;j++;
			num[i] = j;
		}
		else{
			j = num[j];
		}
	}
}
int kmp(int n,int m)
{
	int i = 0,j = 0;
	while(i < n && j < m){
		if(j == -1 || s[i] == p[j]){
			i++;j++;
		}
		else{
			j = num[j];
		}
	}
	if(j == m){
		return i-j+1;
	}
	else{
		return -1;
	}
}
int main()
{
	int n,m,t;
	scanf("%d",&t);
	while(t--){
		scanf("%d%d",&n,&m);
		for(int i = 0;i < n;i++){
			scanf("%d",&s[i]);
		}
		for(int i = 0;i < m;i++){
			scanf("%d",&p[i]);
		}
		get_next(m);
		int ans = kmp(n,m);
		printf("%d\n",ans);
	}
	return 0;
}

願你走出半生,歸來仍是少年~

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章