POJ 3641: 僞素數


——僞素數
原題傳送門

Description

Fermat’s theorem states that for any prime number p and for any integer a > 1, ap = a (mod p).
That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-a pseudoprimes, have this property for some a.
(And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)
Given p and a, determine whether or not p is a base-a pseudoprime.

Data

Input
Input contains several test cases followed by a line containing “0 0”. Each test case consists of a line containing p and a.
Output
For each test case, output “yes” if p is a base-a pseudoprime; otherwise output “no”.

Sample Input
3 2
10 3
341 2
341 3
1105 2
1105 3
0 0
Sample output
no
no
yes
no
yes
yes

2<p≤1000000000 1<a<p

思路

一道關於僞素數的模板題.

僞素數

費馬小定理

瞭解一下
這裏不再詳細介紹,可以查閱其他博主的資料.?

簡單介紹一下思路
對於每一個正整數x:

  • 先判斷x是否爲質數,是就輸出no(Sample 1)
  • 再用快速冪求出k=pow(a,p)%p,判斷k是否等於a即可.

//順便說一下,1105好像是個Carmicheal數.

Code

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define ll long long
using namespace std;
ll a,p;
bool prime(ll x)
{
	if (x==0||x==1) return false;
	for (int i=2;i*i<=x;i++)
		if (x%i==0) return false;
	return true;
}
ll qpow(ll a,ll b,ll p)
{
	ll ans=1;
	while (b>0)
	{
		if (b&1) ans=ans*a%p;
		b>>=1;	
		a=a*a%p;
	} 
	return ans;
}
int main()
{
	while (~scanf("%lld%lld",&p,&a))
	{
		if (p==0||a==0) break;
		if (prime(p))
		{
			printf("no\n");
			continue;
		}
		ll k=qpow(a,p,p);
		if (k==a) printf("yes\n");
		else printf("no\n");
	}
	return 0;
}

感謝奆老關注 qwq ?

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章