HDU 2005 第幾天?

第幾天?

Problem Description
給定一個日期,輸出這個日期是該年的第幾天。

Input
輸入數據有多組,每組佔一行,數據格式爲YYYY/MM/DD組成,具體參見sample input ,另外,可以向你確保所有的輸入數據是合法的。

Output
對於每組輸入數據,輸出一行,表示該日期是該年的第幾天。

Sample Input
1985/1/20
2006/3/12

Sample Output
20
71

#include<stdio.h>

int isLeapYear(int year)
{
    if(year % 400 == 0 || year % 100 != 0 &&year %4 == 0)
        return 1;
    return 0;
}

int main()
{
    int year,month,day;
    int Day[13] = {0, 31, 0, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
    while(scanf("%d/%d/%d",&year, &month, &day) != EOF)
    {
        if(isLeapYear(year))
            Day[2] = 29;
        else
            Day[2] = 28;
        for(int i = 2; i <= month; ++i)
        {
            day += Day[i - 1];
        }
        printf("%d\n",day);
    }
    return 0;
}

如果對代碼有什麼疑惑可以評論問我,也可以私信我,收到將會及時回覆。

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章