HDU 2005 第几天?

第几天?

Problem Description
给定一个日期,输出这个日期是该年的第几天。

Input
输入数据有多组,每组占一行,数据格式为YYYY/MM/DD组成,具体参见sample input ,另外,可以向你确保所有的输入数据是合法的。

Output
对于每组输入数据,输出一行,表示该日期是该年的第几天。

Sample Input
1985/1/20
2006/3/12

Sample Output
20
71

#include<stdio.h>

int isLeapYear(int year)
{
    if(year % 400 == 0 || year % 100 != 0 &&year %4 == 0)
        return 1;
    return 0;
}

int main()
{
    int year,month,day;
    int Day[13] = {0, 31, 0, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
    while(scanf("%d/%d/%d",&year, &month, &day) != EOF)
    {
        if(isLeapYear(year))
            Day[2] = 29;
        else
            Day[2] = 28;
        for(int i = 2; i <= month; ++i)
        {
            day += Day[i - 1];
        }
        printf("%d\n",day);
    }
    return 0;
}

如果对代码有什么疑惑可以评论问我,也可以私信我,收到将会及时回复。

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章