PAT-A-1085 Perfect Sequence 【二分查找】

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤10​5​​) is the number of integers in the sequence, and p (≤10​9​​) is the parameter. In the second line there are N positive integers, each is no greater than 10​9​​.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

這道題使用upper_bound簡直絕了。原因如下:

  • upper_load()返回的是第一個大於所求值得下標,直接減去數組頭就是序列的長度
  • 內部使用二分查找,速度絕對槓槓的

最後一個用例點沒有過,因爲沒有考慮過int溢出的問題,其實一看到題目中指定了數據的範圍是1e9,就應該知道這裏有貓膩。

使用long long 保存乘積

#include <iostream>
#include <vector>
#include <math.h>
#include <algorithm>
using namespace std;
int main(){
	int a,b;
	scanf("%d %d",&a,&b);
	int temp;
	vector<int> data;
	for(int i=0;i<a;i++){
		scanf("%d",&temp);
		data.push_back(temp);
	}
	int max=-1;
	sort(data.begin(),data.end());
	for(int j=0;j<data.size();j++){	
			int len=upper_bound(data.begin()+j+1,data.end(),(long long)b*data[j])-data.begin();
			max=max>len-j?max:len-j;
	}
	printf("%d",max);
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章