PAT-A-1057 Stack 【桶排序】

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian -- return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​5​​). Then N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop
PeekMedian

where key is a positive integer no more than 10​5​​.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print Invalid instead.

Sample Input:

17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

Sample Output:

Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

暴力算法,Stack保存數據,vector維持數據順序,只過了兩個案例。

#include <iostream>
#include <algorithm>
#include <stack>
#include <string.h>
#include <vector>
using namespace std;
int main(){
	int n;
	string flag;
	scanf("%d",&n);
	stack<int> data;
	char s[20];
	vector<int> da;
	int temp;
	for(int l=0;l<n;l++){
		scanf("%s",s);
		if(strlen(s)==3){
			if(data.empty()) printf("Invalid\n");
			else{
				int top=data.top();
				printf("%d\n",top);
				data.pop();
				int index=lower_bound(da.begin(),da.end(),top)-da.begin();
				da.erase(da.begin()+index,da.begin()+index+1);
			}
		}
		else if(strlen(s)==4){
			scanf("%d",&temp);
			data.push(temp);
			da.push_back(temp);
			sort(da.begin(),da.end());
		}
		else{
			if(data.empty()){
				if(data.empty()) printf("Invalid\n");
				continue;
			}
			int size=da.size(),mid;
			if(size%2){
				 mid=da[size/2];
			}else{
			     mid=da[size/2]>da[(size/2)-1]?da[(size/2)-1]:da[size/2];
			}
			printf("%d\n",mid);
			
		}

	}
	
	return 0;
}

 


stack一定不能丟,解決超時的問題一定是要從vector上入手

不使用vector維護數據列表,是用一個大數據維護.使用桶排序的思想來技術

#include <iostream>
#include <algorithm>
#include <stack>
#include <string.h>
#define max 100010
#define v 320
using namespace std;
stack<int> data;
int table[max];
int bucket[v];
void Push(int n){
	data.push(n);
	table[n]++;
	bucket[n/v]++;
}
int Pop(){
	int n=data.top();
	table[n]--;
	bucket[n/v]--;
	data.pop();
	return n;
}


int PeekMedian(){
	int index=(data.size()+1)/2;
	int i=0,j=0;
	while(i+bucket[j]<index){
		i+=bucket[j++];
	}
	int k=j*v;
	while(i+table[k]<index){
		i+=table[k++];
	}
	return k;
}
int main(){
	fill(table,table+max,0);
	fill(bucket,bucket+v,0);
	int N;
	char flag[20];
	scanf("%d",&N);
	for(int l=0;l<N;l++){
		scanf("%s",flag);
		if(strlen(flag)==3){
			if(data.size()==0) printf("Invalid\n");
			else printf("%d\n",Pop());
		}
		else if(strlen(flag)==4){
			int d;
			scanf("%d",&d);
			Push(d);
		}
		else{
			if(!data.size()) printf("Invalid\n");
			else printf("%d\n",PeekMedian());
		}
	}
return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章