PAT-A-1044 Shopping in Mars 【二分查找】 【前綴和】

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​5​​), the total number of diamonds on the chain, and M (≤10​8​​), the amount that the customer has to pay. Then the next line contains N positive numbers D​1​​⋯D​N​​ (D​i​​≤10​3​​ for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + ... + Dj >M with (Di + ... + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

解題思路
利用二分查找
1.將輸入的數組A依次求和得到數組sum,這是sum數組遞增
2.由於sum[i]表示1~i個元素之和,因此sum[j]-sum[i-1]代表i到j的和,且由於sum[j]-sum[i-1] = M 轉化爲查找sum[j] = sum[i-1]+M;
3.第一次遍歷求出大於等於M的最接近M的nears
4.第二次遍歷找出那些值恰好爲nears的方案並輸出.
————————————————
 


#include <iostream>
#include <algorithm>
using namespace std;
int s[100010];                 //保存前綴和,S[i]紀錄從1開始到i的和
int main(){
    int x,y,neary=100000010;
    cin>>x>>y;
    s[0]=0;                    //數組從1開始
    for(int i=1;i<=x;i++){
        cin>>s[i];
        s[i]+=s[i-1];           
    }
    for(int i=1;i<=x;i++){  //枚舉左端點
        int j=lower_bound(s+i,s+x+1,s[i-1]+y)-s;      //lower_bound函數,見函數解析
        if(s[j]-s[i-1]==y){                           //前閉後開,所以右側加了1
            neary=y;                                  //找到break就行
            break;
        }
        else if(s[j]-s[i-1]>=y && s[j]-s[i-1]<neary)  //有大於y的解並小於neary就更新neary
            neary=s[j]-s[i-1];                        
    }
    for(int i=1;i<=x;i++){
        int j=lower_bound(s+i,s+x+1,s[i-1]+neary)-s;  //找出所有等於neary的區間
        if(s[j]-s[i-1]==neary)
            cout<<i<<"-"<<j<<'\n';
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章