Faulty Odometer HDU - 4278

Faulty Odometer HDU - 4278

 You are given a car odometer which displays the miles traveled as an integer. The odometer has a defect, however: it proceeds from the digit 2 to the digit 4 and from the digit 7 to the digit 9, always skipping over the digit 3 and 8. This defect shows up in all positions (the one’s, the ten’s, the hundred’s, etc.). For example, if the odometer displays 15229 and the car travels one mile, odometer reading changes to 15240 (instead of 15230).
Input
  Each line of input contains a positive integer in the range 1..999999999 which represents an odometer reading. (Leading zeros will not appear in the input.) The end of input is indicated by a line containing a single 0. You may assume that no odometer reading will contain the digit 3 and 8.
Output
  Each line of input will produce exactly one line of output, which will contain: the odometer reading from the input, a colon, one blank space, and the actual number of miles traveled by the car.
Sample Input
15
2005
250
1500
999999
0
Sample Output
15: 12
2005: 1028
250: 160
1500: 768
999999: 262143

#include <cstdio>
#include <cstring>
#include <cmath>
#include <iostream>

using namespace std;
int di[10] = {0, 1, 2, 2, 3, 4, 5, 6, 6, 7};

int main(void)
{
    int n, m;
    while (cin >> m && m) {
        int oc = 0;
        int p = 1;
        n = m;
        while (n) {
            int d = n % 10;
            oc += p * di[d];
            p *= 8;
            n /= 10;
        }
        printf("%d: %d\n", m, oc);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章