Hdu 1213

How Many Tables


Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27055 Accepted Submission(s): 13465

Problem Description

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

題解:本題主要考察的是並查集,講究網絡連通性

//Java代碼
import java.util.Scanner;

public class Main {
    static int[] people = new int[1010];
    public static void init(){
        for(int i=1;i<people.length;i++){
            people[i] = i;
        }
    }
    public static int find(int x){//尋找根節點
        if(people[x] == x) return x;
        return find(people[x]);
    }
    public static void uSet(int a,int b){//合併
        int x = find(a);
        int y = find(b);
        if(x != y){
            people[x] = y;
        }
    }
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int T = in.nextInt();
        while(T-- > 0){
            init();
            int N = in.nextInt();
            int M = in.nextInt();
            for(int i=0;i<M;i++){
                int a = in.nextInt();
                int b = in.nextInt();
                uSet(a,b);
            }
            int res = 0;//結果
            for(int i=1;i<=N;i++){
                if(people[i]==i) res++;
            }
            System.out.println(res);//結果輸出
            if(T!=0){
                in.nextLine();
            }
        }

    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章