hdu 4081 Qin Shi Huang's National Road System 【最小生成樹的變形】

                **Qin Shi Huang's National Road System**

        Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
        Total Submission(s): 7448    Accepted Submission(s): 2621

Problem Description
During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China —- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty —- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself “Qin Shi Huang” because “Shi Huang” means “the first emperor” in Chinese.

Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:
There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.
Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people’s life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible —- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads.
Would you help Qin Shi Huang?
A city can be considered as a point, and a road can be considered as a line segment connecting two points.

Input
The first line contains an integer t meaning that there are t test cases(t <= 10).
For each test case:
The first line is an integer n meaning that there are n cities(2 < n <= 1000).
Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.
It is guaranteed that each city has a distinct location.

Output
For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.

Sample Input
2
4
1 1 20
1 2 30
200 2 80
200 1 100
3
1 1 20
1 2 30
2 2 40

Sample Output
65.00
70.00

題目大意:秦始皇準備建造能連通n個國家的道路,徐福說他能免費幫嬴政建一條有魔力的道路,並且他想讓這條路能儘可能的建造在人口多的國家之間,始皇帝想讓道路的總距離最少,最後決定A / B的價值(A與B的比例)必須是最大值,A是由魔法路連接的兩個國家總人口數,B是無魔法道路的總長度。

AC代碼:

# include <cstdio>
# include <cstring>
# include <math.h>

# define MAXN 1005
# define INF 10000000.0

struct POS
{
    int x;
    int y;
    int p;
};

POS p[MAXN];
double map[MAXN][MAXN];
double Gmap[MAXN][MAXN];
int prev[MAXN];
int book[MAXN][MAXN];
int n;
double sum;

double Change(int x1, int y1, int x2, int y2)
{
    return sqrt((x1 - x2) * (x1 - x2) * 1.0 + (y1 - y2) * (y1 - y2) * 1.0 );
}

double max(double a, double b)
{
    return a > b ? a : b;
}

void Prim()
{
    int i, j, k, vis[MAXN];
    double mincost, lowcost[MAXN];
    for (i = 0; i < n; i++)
    {
        lowcost[i] = map[0][i];
        vis[i] = 0;
        prev[i] = 0;
    }
    vis[0] = 1;
    for (i = 0; i < n; i++)
    {
        mincost = INF;
        k = -1;
        for (j = 0; j < n; j++)
        {
            if (!vis[j] && lowcost[j] < mincost)
            {
                mincost = lowcost[j];
                k = j;
            }
        }
        if (-1 == k)
        {
            break;
        }
        sum += mincost;
        vis[k] = 1;
        book[k][prev[k]] = book[prev[k]][k] = 1;
        for (j = 0; j < n; j++)
        {
            if (vis[j] && j != k)
            {               
                Gmap[j][k] = Gmap[k][j] = max(Gmap[j][prev[k]], lowcost[k]);
            }
            if (!vis[j] && map[k][j] < lowcost[j])
            {
                lowcost[j] = map[k][j];
                prev[j] = k;
            }
        }
    }
}

int main(void)
{
    int t;
    scanf("%d", &t);
    while (t--)
    {
        int i, j;
        memset(book, 0, sizeof(book));
        memset(prev, 0, sizeof(book));
        memset(Gmap, 0, sizeof(Gmap));
        sum = 0.0;
        scanf("%d", &n);
        for (i = 0; i < n; i++)
        {
            for (j = 0; j < n; j++)
            {
                map[i][j] = INF;
            }
            map[i][i] = 0.0;
        }
        for (i = 0; i < n; i++)
        {
            scanf("%d %d %d", &p[i].x, &p[i].y, &p[i].p);
        }
        for (i = 0; i < n; i++)
        {
            for (j = i + 1; j < n; j++)
            {
                double dist = Change(p[i].x, p[i].y, p[j].x, p[j].y);
                map[i][j] = map[j][i] = dist;
            }
            map[i][i] = 0.0;
        }
        Prim();
        double result = -1;
        for (i = 0; i < n; i++)
        {
            for (j = i + 1; j < n; j++)
            {
                if (book[i][j])
                {
                    double t = 1.0 * (p[i].p + p[j].p) / (sum - map[i][j]);
                    result = max(result, t);
                }
                else
                {
                    double t = 1.0 * (p[i].p + p[j].p) / (sum - Gmap[i][j]);
                    result = max(result, t);
                }
            }
        }
        printf("%.2lf\n",  result);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章