LightOJ 1259 偶数分解成质数有多少种情况

Description
Goldbach’s conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:
Every even integer, greater than 2, can be expressed as the sum of two primes [1].
Now your task is to check whether this conjecture holds for integers up to107.
Input
Input starts with an integer T (≤ 300), denoting the number of test cases.
Each case starts with a line containing an integern (4 ≤ n ≤ 107, n is even).
Output
For each case, print the case number and the number of ways you can expressn as sum of two primes. To be more specific, we want to find the number of(a, b) where
1) Both a and b are prime
2) a + b = n
3) a ≤ b
Sample Input
2
6
4
Sample Output
Case 1: 1
Case 2: 1
Source
Problem Setter: Jane Alam Jan

题意:找出给出的每个数 两个素数相加的不同形式有多少种;
分析:首先是要找出素数,同时还要找出每对素数相加对应的数;

一开始的想法是线性筛素数,同时开大数组存下每个数的答案,然后。。。。。。
在爆掉几发Memory 之后才开使想其他方法;
在经历了若干发 Memrory和T 之后仔细想了想。

首先注意到我们每次线性筛素数时都会用到访问标记,如果是素数,标记一定是0;
如果不是则为1,再注意到素数的个数不会超过%10,统计素数大概6万个,那么我们每次将给出的数减去每个已知素数 ,在判断剩下的数是否是素数不就行了吗?
考虑最坏情况
6*10^4*300
不会T!

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
const int maxn=10000005;
bool vis[maxn];
int prime[666666];
void is_prime()
{
    int m=sqrt(maxn+0.5);
    memset(vis,false,sizeof(vis));
    vis[1]=true;
    for(int i=2;i<=m;i++)
    {
        if(!vis[i])for(int j=i*i;j<maxn;j+=i)vis[j]=true;
    }
    int s=0;
    for(int i=1;i<maxn;i++)
    {
        if(!vis[i])prime[++s]=i;
    }
}
int main()
{
    int k;
    is_prime();
    cin>>k;
    for(int i=1;i<=k;i++)
    {
        int n,num=0;
        cin>>n;
        for(int i=1;prime[i]<=n/2;i++)
        {
            if(!vis[n-prime[i]])num++;
        }
        printf("Case %d: %d\n",i,num);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章