Buy Tickets poj 2828

Buy Tickets
Time Limit: 4000MS   Memory Limit: 65536K
Total Submissions: 19087   Accepted: 9471

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.


題意給的很明確了,

主要是買票有人插隊,比如,69插在了第二個人的後面,,,


這裏我們要從前往後開始排,想想爲啥呢?

哈哈!當然從後往前可以確定位置

比如第一組

69的前面有兩個空座那他坐在了第三個空座上(記住是空座哦!如果做了人就不是空座了)依照這樣的方式我們可以排一下,

具體我們用線段樹來實現所需功能。


代碼如下:

#include <cstring>
#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;

const int M = 200005;
int no[M<<1+10], num[M];
struct node
{
    int p, v;
}arr[M];

void build(int l, int r, int root)
{
    no[root] = r-l+1;
    if ( l == r )
        return ;
    int mid = (r+l)>>1; //相當於/2
    build(l, mid, root<<1);
    build(mid+1, r, root<<1|1);  //相當於*2+1
}

int query(int p, int l, int r, int top)
{
    no[top]--;
    if ( l == r )
        return l;
    int mid = (l+r)>>1;
    if ( no[top<<1] >= p )
        return query(p, l, mid, top<<1);
    else
        return query(p-no[top<<1], mid+1, r, top<<1|1);
}

int main()
{
    int n, i;
    while ( ~scanf ( "%d", &n ) )
    {
        for ( i = 0;i < n; i++ )
            scanf ( "%d %d", &arr[i].p, &arr[i].v );
        build(1, n, 1);
        for ( i = n-1;i >= 0; i-- )
            num[query(arr[i].p+1, 1, n, 1)] = arr[i].v;
        for ( i = 1;i <= n; i++ )
            printf ( i == n ? "%d\n" : "%d ", num[i] );
    }
    return 0;
}
代碼菜鳥,如有錯誤,請多包涵!!!

如有幫助記得支持我一下,謝謝!!!

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章