POJ-2562-Primary Arithmetic

Primary Arithmetic
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11706   Accepted: 4287

Description

Children are taught to add multi-digit numbers from right-to-left one digit at a time. Many find the "carry" operation - in which a 1 is carried from one digit position to be added to the next - to be a significant challenge. Your job is to count the number of carry operations for each of a set of addition problems so that educators may assess their difficulty.

Input

Each line of input contains two unsigned integers less than 10 digits. The last line of input contains 0 0.

Output

For each line of input except the last you should compute and print the number of carry operations that would result from adding the two numbers, in the format shown below. 

Sample Input

123 456
555 555
123 594
0 0

Sample Output

No carry operation.
3 carry operations.
1 carry operation.

Source


题解:
首先用字符串输入,反向转化成整型,接着对应位置相加,如果相应位相加的和大于9,则需要进位。
注意:
进位数单复数的问题,还有几个字符型常用的函数一定要牢记!

代码:
#include<iostream>
#include <cstring>
using namespace std;
void getNumber(char str[] , int c[])
{
    int i,len = strlen(str);
    for(i = 0 ;i < len ;i++)
    {
        c[i] = str[len - 1 - i]-'0';
    }
}
int main(){
    char a[11],b[11];
    int n[11] = {0}, m[11] = {0}, i, len, num;
    while(cin>>a>>b)
    {
        if(strcmp(a,"0") == 0 && strcmp(b,"0")== 0)
            break;
        num = 0;
        getNumber(a,n);
        getNumber(b,m);
        for(i = 0;i < 11;i++)
        {
            if(n[i] + m[i] > 9)
            {
                n[i+1] += (n[i] + m[i]) / 10;
                n[i] = m[i] = 0;
                num ++;
            }
        }
        if(num == 0)
            cout << "No carry operation." << endl;
        if(num == 1)
            cout << num << " carry operation." << endl;
        if(num > 1) 
            cout << num << " carry operations." << endl;
    }
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章