HDU4278 Faulty Odometer

Description

  You are given a car odometer(里程錶) which displays the miles traveled as an integer(整數). The odometer has a defect(缺點), however: it proceeds(收入) from the digit(數字) 2 to the digit 4 and from the digit 7 to the digit 9, always skipping over the digit 3 and 8. This defect shows up in all positions (the one's, the ten's, the hundred's, etc.). For example, if the odometer displays 15229 and the car travels one mile, odometer reading changes to 15240 (instead of 15230). 

Input

  Each line of input(投入) contains a positive(積極的) integer in the range 1..999999999 which represents an odometer reading. (Leading zeros will not appear in the input.) The end of input is indicated(表明) by a line containing a single 0. You may assume(承擔)that no odometer reading will contain the digit 3 and 8. 

Output

  Each line of input will produce exactly one line of output(輸出), which will contain: the odometer reading from the input, a colon, one blank space, and the actual number of miles traveled by the car. 

Sample Input

15
2005
250
1500
999999
0

Sample Output

15: 12
2005: 1028
250: 160
1500: 768
999999: 262143

這題我做完之後上網搜了一下,發現都是說是由八進制轉化爲十進制,想了一下,確實是這麼回事,然而對我這個各種進制全憑自學的人來說,想轉化成代碼可不容易,而我自己的想法,就是利用dp找每一位所能包含的不含3,8的數的個數,然後一位位加過去就行。

#include <stdio.h>
#include <cstring>

int dp[15],v[15],l;

void init()
{
	int i;
	dp[0]=1;
	for(i=1;i<10;i++)
	{
		dp[i]=dp[i-1]*8;
	}
}

int main()
{
	int i,j;
	int n;
	init();
	while(~scanf("%d",&n)&&n)
	{
		int ans=0;
		l=0;
		int no=n;
		while(n)
		{
			v[l++]=n%10;
			n=n/10;
		}
		for(i=l-1;i>=0;i--)
		{
			if(v[i]>3&&v[i]<8)
				v[i]--;
			else if(v[i]>8)
				v[i]=v[i]-2;
			ans+=dp[i]*v[i];
		}
		printf("%d: %d\n",no,ans);
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章