HDU 4609 3-idiots FFT

3-idiots

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2632    Accepted Submission(s): 900


Problem Description
King OMeGa catched three men who had been streaking in the street. Looking as idiots though, the three men insisted that it was a kind of performance art, and begged the king to free them. Out of hatred to the real idiots, the king wanted to check if they were lying. The three men were sent to the king's forest, and each of them was asked to pick a branch one after another. If the three branches they bring back can form a triangle, their math ability would save them. Otherwise, they would be sent into jail.
However, the three men were exactly idiots, and what they would do is only to pick the branches randomly. Certainly, they couldn't pick the same branch - but the one with the same length as another is available. Given the lengths of all branches in the forest, determine the probability that they would be saved.
 

Input
An integer T(T≤100) will exist in the first line of input, indicating the number of test cases.
Each test case begins with the number of branches N(3≤N≤105).
The following line contains N integers a_i (1≤a_i≤105), which denotes the length of each branch, respectively.
 

Output
Output the probability that their branches can form a triangle, in accuracy of 7 decimal places.
 

Sample Input
2 4 1 3 3 4 4 2 3 3 4
 

Sample Output
0.5000000 1.0000000
 

Source
 


用FFT算出二元和,枚舉最長邊,判重

/** Author: ☆·aosaki(*’(OO)’*)  niconiconi★ **/
//#pragma comment(linker, "/STACK:1024000000,1024000000")
//#include<bits/stdc++.h>
#include <iostream>
#include <sstream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <functional>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <list>
#include <stack>
//#include <tuple>
#define mem(a) memset(a,0,sizeof(a))
#define mem1(a) memset(a,-1,sizeof(a))
#define lp(k,a) for(int k=1;k<=a;k++)
#define lp0(k,a) for(int k=0;k<a;k++)
#define lpn(k,n,a) for(int k=n;k<=a;k++)
#define lpd(k,n,a) for(int k=n;k>=a;k--)
#define sc(a) scanf("%d",&a)
#define sc2(a,b) scanf("%d %d",&a,&b)
#define lowbit(x) (x&(-x))
#define ll long long
#define pi pair<int,int>
#define vi vector<int>
#define PI acos(-1.0)
#define pb(a) push_back(a)
#define mp(a,b) make_pair(a,b)
#define TT cout<<"*****"<<endl;
#define TTT cout<<"********"<<endl;
inline int gcd(int a,int b)
{
    return a==0?b:gcd(b%a,a);
}
#define INF 1e9
#define eps 1e-8
#define mod 10007
#define MAX 400044
using namespace std;


struct complex
{
    double r,i;
    complex(double _r = 0,double _i = 0)
    {
        r = _r; i = _i;
    }
    complex operator +(const complex &b)
    {
        return complex(r+b.r,i+b.i);
    }
    complex operator -(const complex &b)
    {
        return complex(r-b.r,i-b.i);
    }
    complex operator *(const complex &b)
    {
        return complex(r*b.r-i*b.i,r*b.i+i*b.r);
    }
};

void change(complex y[],int len)
{
    int i,j,k;
    for(i=1,j=len/2;i<len-1;i++)
    {
        if(i<j)swap(y[i],y[j]);
        k=len/2;
        while(j>=k)
        {
            j-=k;
            k/=2;
        }
        if(j<k) j+=k;
    }
}

void fft(complex y[],int len,int on)
{
    change(y,len);
    for(int h=2;h<=len;h<<=1)
    {
        complex wn(cos(-on*2*PI/h),sin(-on*2*PI/h));
        for(int j=0;j<len;j+=h)
        {
            complex w(1,0);
            for(int k=j;k<j+h/2;k++)
            {
                complex u=y[k];
                complex t=w*y[k+h/2];
                y[k]=u+t;
                y[k+h/2]=u-t;
                w=w*wn;
            }
        }
    }
    if(on==-1)
        for(int i=0;i<len;i++)
            y[i].r/=len;
}


complex x1[MAX];
int a[MAX/4];
ll num[MAX];//超int!!!
ll sum[MAX];

int main()
{
    //freopen("in.txt","r",stdin);
    int T,n;
    sc(T);
    while(T--)
    {
       sc(n);
       mem(num);
       lp0(i,n)
        {
            sc(a[i]);
            num[a[i]]++;
        }
        sort(a,a+n);
        int len1=a[n-1]+1;
        int len=1;
        while(len<2*len1) len<<=1; //補長
        lp0(i,len1)
            x1[i]=complex(num[i],0);
        lpn(i,len1,len-1)
            x1[i]=complex(0,0); //補0
        fft(x1,len,1);
        lp0(i,len)
            x1[i] = x1[i]*x1[i];
        fft(x1,len,-1);
        for(int i=0;i<len;i++)
            num[i]=(long long)(x1[i].r+0.5); //四捨五入

        len=2*a[n-1]; //最大值
        lp0(i,n)  num[a[i]+a[i]]--;  //兩個相同
        lp(i,len)
        {
            num[i]/=2; //無序,除以2
        }
        sum[0]=0;
        for(int i=1;i<=len;i++)
            sum[i]=sum[i-1]+num[i];
        ll cnt=0;

        lp0(i,n)
        {
            cnt += sum[len]-sum[a[i]];
            cnt -= (ll)(n-1-i)*i;//減掉一個取大,一個取小的
            cnt -= (n-1);//減掉一個取本身,另外一個取其它
            cnt -= (ll)(n-1-i)*(n-i-2)/2;//減掉大於它的取兩個的組合
        }

        ll re=(ll)n*(n-1)*(n-2)/6; //總數
        printf("%.7lf\n",(double)cnt/re);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章