F - Power Network (Dinic 鄰接表+queue)

F - Power Network

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con. 


An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. 

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

 

題意:

            請參考其他博客;

代碼簡介:

            1)自己寫的結構體鄰接表Dinic    79ms;

            2)數組鄰接表  63ms;

            3)fi[] 鄰接表的first[] , ne[] 鄰接表的 next[] 。

            4) 替換fi[] 的 fir[],必須要有。且在 dfs() 中 ,i的循環中 必須加 &。 否則會 TL。   

結構體代碼:

#include<queue>
#include<cmath>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
const int MM=610;
const int MMe=111111;
const int INF=0x3f3f3f3f;
int dis[MM],fi[MM],fir[MM];
int len;
int n,np,nc,m,st,en;
struct Edge
{
    int v,w,ne;
}e[MMe];
void add(int u,int v,int w)
{
    e[len].v=v,e[len].w=w,e[len].ne=fi[u],fi[u]=len++;
    e[len].v=u,e[len].w=0,e[len].ne=fi[v],fi[v]=len++;
}
queue<int>qu;
bool bfs()
{
    mem(dis,-1);
    while(!qu.empty())
        qu.pop();

     dis[st]=0;
    qu.push(st);
    while(!qu.empty())
    {
        int kk=qu.front();
        qu.pop();
        for(int i=fi[kk]; i!=-1; i=e[i].ne)
        {
            int v=e[i].v;
            if(dis[v]==-1 && e[i].w)
            {
                dis[v]=dis[kk]+1;
                qu.push(v);
                if(v==en)
                    return true;
            }
        }
    }
    return false;
}
int dfs(int x,int flow)
{
    int f=0;
    if(x==en)
        return flow;
    for(int &i=fir[x];i!=-1;i=e[i].ne)
     {
        if(dis[e[i].v]==dis[x]+1 && e[i].w &&(f=dfs(e[i].v,min(flow,e[i].w)))>0)
        {
            e[i].w-=f;
            e[i^1].w+=f;
            return f;
        }
     }
    return 0;
}
int dinic()
{
    int ans=0,tmp;
    while(bfs())
    {
        for(int i=0; i<=en; i++)
            fir[i]=fi[i];
        while(tmp= dfs(st,INF))
            ans+=tmp;
    }
    return ans;
}
int main()
{
    while(~scanf("%d%d%d%d",&n,&np,&nc,&m))
    {
        mem(fi,-1);
        len=0;
        int u,v,z;
        for(int i=0;i<m;i++)
        {
           scanf(" (%d,%d)%d",&u,&v,&z);
           add(u+1,v+1,z);
        }
        for(int i=0;i<np;i++)
        {
           scanf(" (%d)%d",&u,&z);
           add(0,u+1,z);
        }
        for(int i=0;i<nc;i++)
        {
            scanf(" (%d)%d",&u,&z);
            add(u+1,n+1,z);
        }
         st=0;
         en=n+1;
        printf("%d\n",dinic());
     }
    return 0;
}

 

數組鄰接表代碼:

#include<queue>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
const int MM=999;
const int MMe=111111;
const int INF=0x3f3f3f3f;
int dis[MM],fi[MM],fir[MM];
int V[MMe],W[MMe],Ne[MMe];
int len;
int n,np,nc,m,st,en;
queue<int>qu;

void add(int u,int v,int w)
{
    V[len]=v,W[len]=w,Ne[len]=fi[u],fi[u]=len++;
    V[len]=u,W[len]=0,Ne[len]=fi[v],fi[v]=len++;
}
bool bfs()
{
    mem(dis,-1);
    while(!qu.empty())
        qu.pop();

    dis[st]=0;
    qu.push(st);
    while(!qu.empty())
    {
        int kk=qu.front();
        qu.pop();
        for(int i=fi[kk]; i!=-1; i=Ne[i])
        {
            int v=V[i];
            if(dis[v]==-1 && W[i])
            {
                dis[v]=dis[kk]+1;
                qu.push(v);
                if(v==en)
                    return true;
            }
        }
    }
    return false;
}
int dfs(int x,int flow)
{
    int f=0;
    if(x==en)
        return flow;
    for(int &i=fir[x]; i!=-1; i=Ne[i])
        if(dis[V[i]]==dis[x]+1 &&  W[i] &&(f=dfs(V[i],min(flow,W[i])))>0)
        {
            W[i]-=f;
            W[i^1]+=f;
            return f;
        }
    return 0;
}
int dinic()
{
    int ans=0,tmp;
    while(bfs())
    {
        for(int i=0; i<=en; i++)
            fir[i]=fi[i];
        while(tmp=dfs(st,INF))
            ans+=tmp;
    }
    return ans;
}
int main()
{
    while(~scanf("%d%d%d%d",&n,&np,&nc,&m))
    {
        mem(fi,-1);
        len=0;
        st=0;
        en=n+1;

        int u,v,z;
        for(int i=1; i<=m; i++)
        {
            while(getchar()!='(');
            scanf("%d,%d)%d",&u,&v,&z);
            add(u+1,v+1,z);
        }
        for(int i=1; i<=np; i++)
        {
            while(getchar()!='(');
            scanf("%d)%d",&u,&z);
            add(0,u+1,z);
        }
        for(int i=1; i<=nc; i++)
        {
            while(getchar()!='(');
            scanf("%d)%d",&u,&z);
            add(u+1,n+1,z);
        }
        printf("%d\n",dinic());
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章