【題解】 HDU 1711 Number Sequence

目錄

 

題目描述

題意分析

AC代碼


題目描述

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 1 3

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 2 1

Sample Output

-1

題意分析

題意: KMP模板題,反覆研習,更得精髓。

 

AC代碼

#include<cstdio>
#include <iostream>
#include <algorithm>
using namespace std;

int s1[1000010],s2[10010];
int Next[10010];
int n,m;
void getNext()
{
    int j,k;
    j=0;
    k=-1;
    Next[0]=-1;
    while(j<m)
    {
        if(k==-1||s2[j]==s2[k])
          Next[++j]=++k;
        else k=Next[k];
    }
}
//返回首次出現的位置
int KMP()
{
    int i=0,j=0;
    getNext();

    while(i<n && j<m)
    {
        if(j==-1||s1[i]==s2[j])
        {
            i++;
            j++;
        }
        else j=Next[j];

    }
    if(j==m) return i-m+1;
    else return -1;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
          scanf("%d",&s1[i]);
        for(int i=0;i<m;i++)
          scanf("%d",&s2[i]);
        printf("%d\n",KMP());
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章