HDU6300 Triangle Partition

Triangle Partition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 581    Accepted Submission(s): 303
Special Judge

 

Problem Description

Chiaki has 3n points p1,p2,…,p3n. It is guaranteed that no three points are collinear.
Chiaki would like to construct n disjoint triangles where each vertex comes from the 3n points.

 

 

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤1000) -- the number of triangle to construct.
Each of the next 3n lines contains two integers xi and yi (−109≤xi,yi≤109).
It is guaranteed that the sum of all n does not exceed 10000.

 

 

Output

For each test case, output n lines contain three integers ai,bi,ci (1≤ai,bi,ci≤3n) each denoting the indices of points the i-th triangle use. If there are multiple solutions, you can output any of them.

 

 

Sample Input


 

1 1 1 2 2 3 3 5

 

 

Sample Output


 

1 2 3

 題意:

給你n個三角形,再給你3n個點,然後讓你將所有點進行分配,讓任意兩個三角形不相交,而且在其中不會有三個點共線的情況。

算法:

說不上什麼算法,你就是結構體排序一下,然後從左往右每三個就輸出就行了,因爲在其中不會三個點共線,所以最多兩個共線,這樣就保證了不會有線相交。

代碼:

#include<stdio.h>
#include<algorithm>
using namespace std;

struct point
{
    int x,y,id;
}p[3005];

bool cmp(point u,point v)
{
    if(u.x == v.x) return u.y > v.y;
    return u.x < v.x;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        for(int i = 0 ; i < 3*n ; i ++)
        {
            scanf("%d%d",&p[i].x,&p[i].y);
            p[i].id = i+1;
        }
        sort(p,p+(3*n),cmp);
        for(int i = 0 ; i < 3*n ; i += 3)
        {
            printf("%d %d %d\n",p[i].id,p[i+1].id,p[i+2].id);
        }
    }
    return 0;
}

補題才過,一開始沒看這題,覺得這題更簡單............自己太菜了。

菜得不一樣,菜出新高度。

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章