課程練習四-problem V

Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together. <br><center><img src=../../../data/images/C308_1004_1.jpg></center><br>His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls. <br>Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.
 

Input
The first line of the input is a single positive integer T(0 < T <= 100). <br>For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).<br>Each of the following Q lines contains either a fact or a question as the follow format:<br> T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.<br> Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
 

Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
 

Sample Input
2 3 3 T 1 2 T 3 2 Q 2 3 4 T 1 2 Q 1 T 1 3 Q 1
 

Sample Output
Case 1: 2 3 0 Case 2: 2 2 1 3 3 2

 

題意:

有N的龍珠,編號爲1~N,開始時分別分佈在編號爲1~N的城市。

然後如果是輸入T a b,那麼進行移動, 把編號a的龍珠所在的城市的所有龍珠移動到編號b龍珠所在的城市。

輸入Q a, 那麼輸出a龍珠所在的城市, a龍珠所在城市有的龍珠的個數, 以及a龍珠移動的次數。


思路:


代碼:

#include<iostream>  
#include<cstdio>  
#include<cstring>  
#define MAXN 10002  
using namespace std;  
int N, Q, father[MAXN], rank[MAXN], num[MAXN];  
  
void init(){  
    for(int i=1; i<=N; ++i){  
        father[i] = i, rank[i] = 1, num[i]=0;  
    }  
}  
  
int find(int x){  
    if(x==father[x]) return x;  
    int t=father[x];  
    father[x] = find(father[x]);  
    num[x] += num[t];  
    return father[x];   
}  
  
void Union(int x,int y){  
    int a=find(x);  
    int b=find(y);  
    if(a!=b){  
        father[a] = b;  
        rank[b] += rank[a];  
        num[a] = 1; // 這是球a第一次移動  
    }  
}  
  
  
int main(){  
#ifdef LOCAL  
    freopen("input.txt","r",stdin);  
#endif  
    int T,a,b,k,cas=1;  char cmd[2];  
    scanf("%d", &T);  
    while(T--){  
        printf("Case %d:\n",cas++);  
        scanf("%d %d", &N,&Q);  
        init();  
        for(int i=0; i<Q; ++i){  
            scanf("%s", cmd);  
            if(cmd[0]=='T'){  
                scanf("%d %d", &a, &b);  
                Union(a, b);  
            }  
            else{  
                scanf("%d", &k);  
                int x = find(k);  
                int cnt=0;  
                printf("%d %d %d\n", x, rank[x],num[k]);   
            }  
        }  
    }  
    return 0;  

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章