POJ Find them, Catch them 1703 (關係型並查集)

Find them, Catch them
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 42711   Accepted: 13146

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source



題意:n個犯人,D表示這兩個犯人不在同一個城市,A是詢問,如果在同一城市In the same gang.如果不在In different gangs.都不是Not sure yet.


關係型並查集,和poj1182差不多http://blog.csdn.net/ky961221/article/details/53383349


建一個N*2的並查集,1--N代表第一個城市

                                   N+1--N*2代表第二個城市

  

當D的時候,只需建立x和y+n,x+n和y的關係,表示x和y相對的城市在一塊....

當A的時候,先判斷是他們是否在同一個城市(x,y)

    如果不是,再判斷他們是否在不同的城市(x,y+n)或(x+n,y)

    前面兩種都不是,就是他們的關係沒有出現過


#include <iostream>
#include <stdio.h>
using namespace std;
#define N 112345
int pre[N<<1];
int Find(int x)
{
    if(x!=pre[x])
        pre[x]=Find(pre[x]);
    return pre[x];
}
void mix(int x,int y)
{
    x=Find(x);
    y=Find(y);
    if(x!=y)
        pre[x]=y;
}
bool panduan(int x,int y)
{
    if(Find(x)==Find(y))
        return true;
    else
        return false;
}
void init(int n)
{
    for(int i=1;i<=n*2;i++)
        pre[i]=i;
}
int main()
{
    int t;
    int x,y;
    int n,m,i,j;
    char s[5];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        init(n);
        while(m--)
        {
            scanf("%s%d%d",s,&x,&y);
            if(s[0]=='D')
            {
                mix(x,y+n);
                mix(x+n,y);
            }
            if(s[0]=='A')
            {
                if(panduan(x,y))
                {
                    printf("In the same gang.\n");
                }
                else if(panduan(x,y+n)||panduan(x+n,y))
                {
                    printf("In different gangs.\n");
                }
                else
                {
                    printf("Not sure yet.\n");
                }
            }
        }
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章