poj to the max(最大子矩陣和) 1050(dp大法)

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15


這道題是由最大字段和問題延伸而來,最大子段和問題是一維,而這道題是二維。

所以想辦法把它降爲一維。然後發現上下相加不就成爲一維的嘛。

然後遍歷一下,讓所有情況都計算一下,得出最大值;

詳細參考:http://blog.csdn.net/beiyeqingteng/article/details/7056687

代碼:

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int dp[102][102];
//最大子段和問題,算出一維的最大
int maxsub(int n,int a[])
{
    int i,sum=0,b=0;
    for(i=1; i<=n; i++)
    {
        if(b>0)b+=a[i];
        else b=a[i];
        if(b>sum)sum=b;
    }
    return sum;
}
int main()
{
    int b[102];
    int n,i,k,j,sum,maxsum;
    while(scanf("%d",&n)!=EOF)
    {
        
        //存圖
        for(i=1; i<=n; i++)
        {
            for(j=1; j<=n; j++)
            {
                scanf("%d",&dp[i][j]);
            }
        }
        
        //將二維壓至一維
        maxsum=0;
        for(i=1; i<=n; i++)//用來遍歷所有的情況
        {
            
            //b是用來存入上下和的值
            memset(b,0,sizeof(b));
            for(j=i; j<=n; j++)//行
            {
                for(k=1; k<=n; k++)//列
                {
                    b[k]+=dp[j][k];
                }
                sum=maxsub(n,b);
                if(sum>maxsum)maxsum=sum;
            }
        }
        printf("%d\n",maxsum);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章