二分匹配--Machine Schedule

Machine Schedule

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem. 

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y. 

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y. 

The input will be terminated by a line containing a single zero. 

Output

The output should be one integer per line, which means the minimal times of restarting machine. 

Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output

3

題目大意:有兩臺機器A和B,A機器有n種工作方式,B機器有m種工作方式。共有k個任務。每個任務恰好在一條機器上運行。

如果任務在A機器上運行,就需要轉換爲模式Xi,如果在B機器上運行,就需要轉換爲模式Yi。

每臺機器上的任務可以按照任意順序執行,但是每臺機器每轉換一次模式需要重啓一次。

請合理爲每個任務安排一臺機器併合理安排順序,使得機器重啓次數儘量少。

 

解題思路:(轉)

把機器A的N種模式作爲二分圖的左部,機器B的M種模式作爲二分圖的右部,如果某個任務可以使用機器A的模式xi也可以使用機器B的模式yi完成,則連接xi,yi。

題目要求使機器重啓的次數要儘量少,又要把所有的任務都執行完,也就可以把題目轉換成最小頂點覆蓋,根據二分圖的性質:最小頂點覆蓋=最大匹配數。

 

#include<stdio.h>
#include<string.h>
#define MAX  110

int line[MAX][MAX];//連接一個作業的兩個mode 
int used[MAX];//中間值 
int n,m;//n-->A機器的mode數,m-->B機器的mode數 
int mode[MAX];//表示mode的使用情況 

bool find(int x){
	for(int j = 1;j<=m;j++){
		if(line[x][j]==true&&used[j]==false){
			used[j] = 1;
			if(mode[j]==0||find(mode[j])){
				mode[j] = x;
				return true;
			}
		}
	}
	return false;
}

int main(){
	int k;//k個作業 
	while(scanf("%d",&n)!=EOF&&n!=0){
		//初始化
		memset(line,0,sizeof(line));
		memset(mode,0,sizeof(mode)); 
		//輸入 
		scanf("%d%d",&m,&k);
		int a,b,c;
		for(int i = 0;i<k;i++){
			scanf("%d%d%d",&a,&b,&c);
			line[b][c] = 1;
		}
		//核心算法
		int all = 0;
		for(int i =1;i<=n;i++){
			memset(used,0,sizeof(used));
			if(find(i)) all++;
		} 
		//輸出
		printf("%d\n",all); 
	}
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章