最小生成樹--Building a Space Station

Building a Space Station

You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task. 
The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible. 

All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor', or (3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively. 

You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with the shortest total length of the corridors. 

You can ignore the width of a corridor. A corridor is built between points on two cells' surfaces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect. 

Input

The input consists of multiple data sets. Each data set is given in the following format. 


x1 y1 z1 r1 
x2 y2 z2 r2 
... 
xn yn zn rn 

The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100. 

The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after the decimal point. Values are separated by a space character. 

Each of x, y, z and r is positive and is less than 100.0. 

The end of the input is indicated by a line containing a zero. 

Output

For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001. 

Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000. 

Sample Input

3
10.000 10.000 50.000 10.000
40.000 10.000 50.000 10.000
40.000 40.000 50.000 10.000
2
30.000 30.000 30.000 20.000
40.000 40.000 40.000 20.000
5
5.729 15.143 3.996 25.837
6.013 14.372 4.818 10.671
80.115 63.292 84.477 15.120
64.095 80.924 70.029 14.881
39.472 85.116 71.369 5.553
0

Sample Output

20.000
0.000
73.834

 

測試樣例分析: 

 

#include<stdio.h>
#include<math.h>
#include<algorithm>
#define MAX 1005
using namespace std;

int n,index;//n表示細胞的數量,index表示索引 
int fa[MAX];//表示頂點所屬集合 

struct Cell{ //細胞的相關數據 
	double x,y,z;
	double r;
}cell[MAX];

struct Edge{//兩個細胞的距離 
	int start,end;
	double dis;
	const bool operator< (const Edge&rhs)const{
		return dis<rhs.dis;
	}
}edge[MAX*MAX];

double between(Cell v,Cell u){//計算距離 
	double x = (v.x-u.x)*(v.x-u.x);
	double y = (v.y-u.y)*(v.y-u.y);
	double z = (v.z-u.z)*(v.z-u.z);
	double Long = sqrt(x+y+z)-v.r-u.r;
	if(Long < 0)	return 0;
	else	return Long;
}

int find(int x){//找根節點 
	if(fa[x]==x) return x;
	else return fa[x]=find(fa[x]);
}

double Kruskal(){
	double ans = 0;//表示答案 
	int cnt = 0;//找到邊的數目 
	for(int i = 1;i<=MAX;i++)//初始化 
		fa[i] = i; 
	sort(edge+1,edge+1+index);//排序所有邊 
	for(int i = 1;i<=index;i++){
		int x = find(edge[i].start);
		int y = find(edge[i].end);
		if(x!=y){//若兩個細胞的所屬集合不同 
			ans += edge[i].dis;//把該邊距離加入 
			fa[x] = y;//更新細胞所屬集合 
			cnt++;
		}
		if(cnt == n-1) break; //到完n-1條邊 
	}
	return ans;
}

int main(){
	while(scanf("%d",&n)&&n!=0){
		//初始化 
		index = 0;
		
		//輸入 
		for(int i = 1;i<=n;i++){
			scanf("%lf%lf%lf%lf",&cell[i].x,&cell[i].y,&cell[i].z,&cell[i].r);
			for(int j = 1;j<i;j++){
				edge[++index].start = j;
				edge[index].end = i;
				edge[index].dis = between(cell[i],cell[j]);
			}
		}
		
		//運算 
		double cost = Kruskal();
		
		//輸出 
		printf("%.3f\n",cost);
	} 
	return 0;
} 

注意index的值,我wa幾次,最後才發現index多加了一次,真滴無奈啊(π^π)

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章