二分匹配--Air Raid

Air Raid

Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection i.e. the town's streets form no cycles. 

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper. 

Input

Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format: 

no_of_intersections 
no_of_streets 
S1 E1 
S2 E2 
...... 
Sno_of_streets Eno_of_streets 

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections. 

There are no blank lines between consecutive sets of data. Input data are correct. 

Output

The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town. 

Sample Input

2
4
3
3 4
1 3
2 3
3
3
1 3
1 2
2 3

Sample Output

2
1

題意:

一個地圖上有n個小鎮,以及連接着其中兩個小鎮的有向邊,而且這些邊無法形成迴路。現在選擇一些小鎮空降士兵(1個小鎮最多1個士兵),士兵能沿着邊走到盡頭,問最少空降幾個士兵,能遍歷完所有的小鎮。

思路:最小路徑覆蓋 = 節點數 - 最大匹配數 

#include<stdio.h>
#include<string.h>
#define MAX 200

int line[MAX][MAX];
int n,m;//n-->十字路口數 m-->街道數
int used[MAX];
int linker[MAX];

bool find(int x){
	for(int j = 1;j<=n;j++){
		if(line[x][j]==true&&used[j]==false){
			used[j] = 1;
			if(linker[j]==0||find(linker[j])){
				linker[j] = x;
				return true;
			} 
		}
	}
	return false;
}

int main(){
	int cases;
	scanf("%d",&cases);
	while(cases--){
		//初始化
		memset(line,0,sizeof(line));
		memset(linker,0,sizeof(linker)); 
		//輸入 
		scanf("%d%d",&n,&m);
		for(int i = 0;i<m;i++){
			int a,b;
			scanf("%d%d",&a,&b);
			line[a][b] = 1;
		}
		//核心算法
		int all = 0;
		for(int i = 1;i<=n;i++){
			memset(used,0,sizeof(used));
			if(find(i)) all++;
		} 
		//輸出
		printf("%d\n",n-all); 
	}
	return 0;
} 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章