2017微软秋季校园招聘在线编程笔试(第二题)

时间限制:10000ms
单点时限:1000ms
内存限制:256MB

描述

Alice writes an English composition with a length of N characters. However, her teacher requires that M illegal pairs of characters cannot be adjacent, and if 'ab' cannot be adjacent, 'ba' cannot be adjacent either.

In order to meet the requirements, Alice needs to delete some characters.

Please work out the minimum number of characters that need to be deleted.

输入

The first line contains the length of the composition N.

The second line contains N characters, which make up the composition. Each character belongs to 'a'..'z'.

The third line contains the number of illegal pairs M.

Each of the next M lines contains two characters ch1 and ch2,which cannot be adjacent.  

For 20% of the data: 1 ≤ N ≤ 10

For 50% of the data: 1 ≤ N ≤ 1000  

For 100% of the data: 1 ≤ N ≤ 100000, M ≤ 200.

输出

One line with an integer indicating the minimum number of characters that need to be deleted.

样例提示

Delete 'a' and 'd'.

样例输入
5
abcde
3
ac
ab
de
样例输出
2

解题思路:

        一个动态规划的题目,f[i]代表以第i个字母(0-25)结尾的最长的子串,对于字符串上每一个字符k都有删和不删两种选择,如果删除,则f[i]不变,如果不删除,则f[k]为满足不相邻的条件的最长的f[i]+1。

代码:

#include <cstdio>
#include <cstring>

using namespace std;

int n,m;
char s[100005];
bool a[30][30];
int f[30];

int main()
{
    scanf("%d",&n);
    scanf("%s",s);
    scanf("%d",&m);
    memset(a,true,sizeof(a));
    for(int i = 0; i < m; i ++){
        char temp[10];
        scanf("%s",temp);
        a[temp[0]-'a'][temp[1]-'a'] = false;
        a[temp[1]-'a'][temp[0]-'a'] = false;
    }
    memset(f,0,sizeof(f));
    int length = strlen(s);
    for(int i = 0; i < length ; i ++){
        int maxN = 0;
        for(int j = 0; j < 26; j ++){
            if(f[j] > maxN && a[j][s[i] - 'a']) maxN = f[j];
        }
        f[s[i] - 'a'] = maxN + 1;
    }
    int ans = 0;
    for(int i = 0; i < 26; i ++){
        if(f[i] > ans) ans = f[i];
    }
    printf("%d\n",length - ans);
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章