【PAT 甲级】1001 A+B Format

1001 A+B Format (20)(20 分)

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

题目大意:求两个数的和,并用三位分节法表示结果。

注意这里用到了一个新的取整数位数的方法,参考:点击打开链接

	if(abs(sum)>1)
	{//取整数位数
	        len=1+(int)log10(abs(sum));
	}

我的完整代码如下:

#include <iostream>
#include <cmath>
#include <string>
using namespace std;
int main()
{
	int a,b,sum,i=1,temp,len=1;
	cin>>a>>b;

	sum=a+b;
	if(abs(sum)>1)
	{//取整数位数
	        len=1+(int)log10(abs(sum));
	}
	int *s= new int [len+2]; //动态分配数组
	
	if(sum==0)
	{//如果合为0,直接输出0
		cout<<'0';
		system("pause");
		return 0;
	}
	temp=sum;

	while(sum!=0)
	{//从个位开始逐位存入
		s[i]=sum%10;
		sum=sum/10;
		i++;
	}

	//输出
	if(temp<0)
	{
		cout<<'-';
	}
	for(int j=i-1;j>=1;j--)
	{
		if(j%3==0&&j!=i-1)
		{
			cout<<',';
		}
		cout<<abs(s[j]);
	}

        delete[] s;
	system("pause");
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章