hdu 5441 Travel(並查集)

Travel

Time Limit: 1500/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 4222 Accepted Submission(s): 1413

Problem Description
Jack likes to travel around the world, but he doesn’t like to wait. Now, he is traveling in the Undirected Kingdom. There are n cities and m bidirectional roads connecting the cities. Jack hates waiting too long on the bus, but he can rest at every city. Jack can only stand staying on the bus for a limited time and will go berserk after that. Assuming you know the time it takes to go from one city to another and that the time Jack can stand staying on a bus is x minutes, how many pairs of city (a,b) are there that Jack can travel from city a to b without going berserk?

Input
The first line contains one integer T,T≤5, which represents the number of test case.

For each test case, the first line consists of three integers n,m and q where n≤20000,m≤100000,q≤5000. The Undirected Kingdom has n cities and m bidirectional roads, and there are q queries.

Each of the following m lines consists of three integers a,b and d where a,b∈{1,…,n} and d≤100000. It takes Jack d minutes to travel from city a to city b and vice versa.

Then q lines follow. Each of them is a query consisting of an integer x where x is the time limit before Jack goes berserk.

Output
You should print q lines for each test case. Each of them contains one integer as the number of pair of cities (a,b) which Jack may travel from a to b within the time limit x.

Note that (a,b) and (b,a) are counted as different pairs and a and b must be different cities.

Sample Input
1
5 5 3
2 3 6334
1 5 15724
3 5 5705
4 3 12382
1 3 21726
6000
10000
13000

Sample Output
2
6
12


多次詢問,給出最大忍耐值,求有多少對城市能到達(A,B)(B,A)


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;
#define N 20005
#define M 100005
int t, n, m, q, ans;
int num[N], p[N], sum[N];
struct node{
    int x, y, w;
    bool operator < ( const node &a ) const{
        return w < a.w;
    }
}nod[M];
struct question{
    int id, w;
    bool operator < (const question &a ) const{///
        return w < a.w;
    }
}qu[N];
void init()
{
    for( int i = 0 ; i <= n ; i ++ ){
        p[i] = i;
        num[i] = 1;
    }
}
int fnd( int x ) { return p[x] = p[x] == x ? x : fnd( p[x] ); }

void unite( int x, int y )///
{
    if( x < y ) swap( x, y );
    p[x] = y;
    num[y] += num[x];///
    //printf( "%d %d\n", num[y], num[x] );
}
int main()
{
    freopen( "in.txt", "r", stdin );
    scanf( "%d", &t );
    while( t -- ){
        scanf( "%d%d%d", &n, &m, &q );
        init();
        for( int i = 0 ; i < m ; i ++ ){
            scanf( "%d%d%d", &nod[i].x, &nod[i].y, &nod[i].w );
        }
        sort( nod, nod+m );
        for( int i = 0 ; i < q ; i ++ ){
            qu[i].id = i;///
            scanf( "%d", &qu[i].w );
        }
        sort( qu, qu+q );///
        int j = 0;
        ans = 0;
        for( int i = 0 ; i < q ; i ++ ){///
            while( j < m && nod[j].w <= qu[i].w ){///
                int u = fnd( nod[j].x );
                int v = fnd( nod[j].y );
                j ++;
                if( u == v ) continue;
                ans += (num[u]+num[v])*(num[u]+num[v]-1) - num[u]*(num[u]-1) - num[v]*(num[v]-1);///
                unite( u, v );
            }
            sum[qu[i].id] = ans;//printf( " %d\n", qu[i].id );
        }
        for( int i = 0 ; i < q ; i ++ ){
            printf( "%d\n", sum[i] );
        }
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章