HDU 1157 Who's in the Middle

Who's in the Middle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19585    Accepted Submission(s): 8635



Problem Description
FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less.

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
 

Input
* Line 1: A single integer N

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
 

Output
* Line 1: A single integer that is the median milk output.
 

Sample Input
5 2 4 1 3 5
 

Sample Output
3
Hint
INPUT DETAILS: Five cows with milk outputs of 1..5 OUTPUT DETAILS: 1 and 2 are below 3; 4 and 5 are above 3.
這個題很簡單,真的很簡單,我腦殘了一下
 
#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
	int n,num[10010];
	while(cin>>n)//這裏雖然題目裏沒明說,但是你不加就是WA,親身經歷...
	{
		for (int i=0;i<n;i++)
		{
			cin>>num[i];
		}
		sort(num,num+n);
		cout<<num[n/2]<<endl;
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章