HDU 2095 find your present (2)

find your present (2)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 24959    Accepted Submission(s): 9894



Problem Description
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.
 

Input
The input file will consist of several cases.
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.
 

Output
For each case, output an integer in a line, which is the card number of your present.
 

Sample Input
5 1 1 3 2 2 3 1 2 1 0
 

Sample Output
3 2
Hint
Hint
use scanf to avoid Time Limit Exceeded
這個題用一般套路很容易超時,所以這裏用一個new方法,異或
舉一個例子。    如 數據  1 2 3 2 1       先讓result=0    那麼可以看成是  result^1^2^3^2^1         交換律     result^1^1^2^2^3        很明顯      1^1 和  2^2 都爲 0        所以最後得    result^3 =0^3 =3(二進制 101)
怎樣很容易理解吧大笑
#include<stdio.h>
int main()
{
   int i,k,n,s;
   while(scanf("%d",&n),n)
   {
	   s=0;
		for(i=0;i<n;i++)
		{
		  scanf("%d",&k);
		  s^=k;
		}
	   printf("%d\n",s);
   }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章