hdu 3501 Calculation 2 (歐拉函數的延伸)

Calculation 2

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3422    Accepted Submission(s): 1413


Problem Description
Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.
 

Input
For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
 

Output
For each test case, you should print the sum module 1000000007 in a line.
 

Sample Input
3 4 0
 

Sample Output
0 2
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

long long euler(long long n){
     long long res=n,a=n;
     for(long long i=2;i*i<=a;i++){
         if(a%i==0){
             res=res/i*(i-1);
             while(a%i==0) a/=i;
         }
     }
     if(a>1) res=res/a*(a-1);
     return res;
}
int main(){
	long long n,s;
	while(scanf("%lld",&n),n){
		s=n*(n-1)/2;
		s=s-euler(n)*n/2;
		printf("%lld\n",s%1000000007);
	}
	return 0;
}  



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章