【POJ3252】Round Numbers 數位DP

Round Numbers

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 15305 Accepted: 6215

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone’ (also known as ‘Rock, Paper, Scissors’, ‘Ro, Sham, Bo’, and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can’t even flip a coin because it’s so hard to toss using hooves.

They have thus resorted to “round number” matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both “round numbers”, the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a “round number” if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many “round numbers” are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start..Finish

Sample Input

2 12

Sample Output

6

題解

數位Dp學習筆記
題目中要求,範圍內二進制的數中0出現的次數大於1出現的次數。
我們只需要把區間變成二進制,然後在dfs 的時候枚舉二進制就可以,狀態的話記錄二進制中0 出現的次數與1 出現的次數的差,注意要加上32 ,數組中不能有負下標

代碼

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
const int MAXN=1030;
int n,m;
int a[MAXN],b[MAXN],num,dp[1000][1000];
int dfs(int pos,int S,int lead,int limit)
{
    if(pos==-1) 
        return S>=32;
    if(dp[pos][S]!=-1&&(!limit)&&(!lead)) 
        return dp[pos][S];
    int Tmp=0;
    int up=limit ? b[pos] : 1;
    for(int i=0;i<=up;i++)
    {
        if(lead && i==0) 
            Tmp+=dfs(pos-1,S,lead,limit&&i==b[pos]);
        else
            Tmp+=dfs(pos-1,S+(i==0 ? 1 : -1),lead && i==0,limit && i==b[pos]);
    }
    if(!limit&&(!lead)) 
        dp[pos][S]=Tmp;
    return Tmp;
}
int solve(int x)
{
    int num=0;
    while(x)
    {
        if(x&1) 
            b[num++]=1;
        else
            b[num++]=0;
        x>>=1;
    }
    return dfs(num-1,32,1,1);
}
int main()
{
    memset(dp,-1,sizeof(dp));
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        printf("%d\n",solve(m)-solve(n-1)); 
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章