ZOJ 3956 Course Selection System (01揹包)

Course Selection System


Time Limit: 1 Second      Memory Limit: 65536 KB


There are n courses in the course selection system of Marjar University. The i-th course is described by two values: happiness Hi and credit Ci. If a student selects m courses x1, x2, ..., xm, then his comfort level of the semester can be defined as follows:

$$(\sum_{i=1}^{m} H_{x_i})^2-(\sum_{i=1}^{m} H_{x_i})\times(\sum_{i=1}^{m} C_{x_i})-(\sum_{i=1}^{m} C_{x_i})^2$$

 

Edward, a student in Marjar University, wants to select some courses (also he can select no courses, then his comfort level is 0) to maximize his comfort level. Can you help him?

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains a integer n (1 ≤ n ≤ 500) -- the number of cources.

Each of the next n lines contains two integers Hi and Ci (1 ≤ Hi ≤ 10000, 1 ≤ Ci ≤ 100).

It is guaranteed that the sum of all n does not exceed 5000.

We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each case, you should output one integer denoting the maximum comfort.

Sample Input

2
3
10 1
5 1
2 10
2
1 10
2 10

Sample Output

191
0

Hint

For the first case, Edward should select the first and second courses.

For the second case, Edward should select no courses.

題意:

給你n件物品,每件物品有兩個屬性h[i],c[i],你需要任選m件,使$$(\sum_{i=1}^{m} H_{x_i})^2-(\sum_{i=1}^{m} H_{x_i})\times(\sum_{i=1}^{m} C_{x_i})-(\sum_{i=1}^{m} C_{x_i})^2$$最大。

思路:

考慮H*H-H*C-C*C

把C看爲常數,則式子變爲H*H-c*H-c*c。顯然H越大,答案越大。

因此把c[i]當做重量,h[i]當做價值做一個01揹包,然後枚舉C,求一個最大的dp[C]*dp[C]-C*dp[C]-C*C即可。

代碼:

#include<bits/stdc++.h>
#define rep(i,a,b) for(register int i=(a);i<=(b);i++)
#define dep(i,a,b) for(register int i=(a);i>=(b);i--)
#define inf 0x3f3f3f3f
using namespace std;
typedef long long ll;
const int maxn=2e5+10;
int n,m,k;
int x,y,z;
ll tmp,cnt,ans,sum;
ll a[maxn],h[maxn];
ll dp[50005];
int main()
{
    int T,cas=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        memset(dp,0,sizeof(dp));
        int sum=0;
        rep(i,1,n)
        {
            scanf("%lld%lld",&h[i],&a[i]);
            sum+=a[i];
        }
        ll ans=0;
        rep(i,1,n){
            for(int j=sum;j>=a[i];j--)
            {
                dp[j]=max(dp[j],dp[j-a[i]]+h[i]);
                ans=max(ans,dp[j]*dp[j]-dp[j]*j-(ll)j*j);
            }
        }
        printf("%lld\n",ans);
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章