HDU 6045 Is Derek lying?【思維】

題目來戳呀

Problem Description

Derek and Alfia are good friends.Derek is Chinese,and Alfia is Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at intervals.The test consists of N choice questions and each question is followed by three choices marked “A” “B” and “C”.Each question has only one correct answer and each question is worth 1 point.It means that if your answer for this question is right,you can get 1 point.The total score of a person is the sum of marks for all questions.When the test is over,the computer will tell Derek the total score of him and Alfia.Then Alfia will ask Derek the total score of her and he will tell her: “My total score is X,your total score is Y.”But Derek is naughty,sometimes he may lie to her. Here give you the answer that Derek and Alfia made,you should judge whether Derek is lying.If there exists a set of standard answer satisfy the total score that Derek said,you can consider he is not lying,otherwise he is lying.

Input

The first line consists of an integer T,represents the number of test cases.

For each test case,there will be three lines.

The first line consists of three integers N,X,Y,the meaning is mentioned above.

The second line consists of N characters,each character is “A” “B” or “C”,which represents the answer of Derek for each question.

The third line consists of N characters,the same form as the second line,which represents the answer of Alfia for each question.

Data Range:1≤N≤80000,0≤X,Y≤N,∑Ti=1N≤300000

Output

For each test case,the output will be only a line.

Please print “Lying” if you can make sure that Derek is lying,otherwise please print “Not lying”.

Sample Input

2
3 1 3
AAA
ABC
5 5 0
ABCBC
ACBCB

Sample Output

Not lying
Lying

題意:

有n道題,每道題有3個選項,我和你做,我得X分,你得Y分,但我可能騙你,根據兩個人的答案來判斷我有沒有騙你。

想法:

分數=相同答案的得分數+不同答案的得分數
首先,兩個人的得分之差一定<=不同的答案數,即abs(y-x)<=(n-same)
其次,來討論兩個人得分之和 x+y<=n+same
證法1:
得分之和max時,就是兩個人相同答案都是對的,並且一定有人在不同答案裏得分(無非就是我對你錯你對我錯,不同答案的分數兩人分了 ),不能讓兩個人都錯(都錯會使分數流失),所以(x+y)max=same+same+n-same=n+same。
證法2:
可以由你的得分來推測我的。
我得分最大值=相同答案的全對+我在不同答案得分數=相同答案的全對+不同答案總得分數-你在不同答案的得分數,所以(x)max=same+n-same-(y-same)=n-y+same

同時滿足兩個條件則我沒有在騙你~

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char a[80004],b[80004];
int main()
{
    int t,n,x,y;
    scanf("%d",&t);
    while(t--)
    {
        int cnt=0;
        scanf("%d %d %d",&n,&x,&y);
        scanf("%s",a);
        scanf("%s",b);
        for(int i=0; i<n; ++i)
        {
            if(a[i]==b[i])
                cnt++;
        }
        if(x<=(n-y+cnt)&&abs(y-x)<=(n-cnt))
            printf("Not lying\n");
        else
            printf("Lying\n");
    }
    return 0;
}

ps:想通了就是很簡單的思維題啊QAQ 不知道我講的清不清楚~

發佈了87 篇原創文章 · 獲贊 8 · 訪問量 3萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章