POJ2485 Highways

Highways
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 27173   Accepted: 12421

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed. 
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692

Hint

Huge input,scanf is recommended.

題意:求出最小生成樹中,最長的那一段,還是比較裸的Prim

代碼 如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define MAXN 700
using namespace std;

int sum,n;
int dis[MAXN][MAXN];
int cost[MAXN];
bool vis[MAXN];
const int INF=0x3f3f3f;

void Prim(int start)
{
	memset(vis,0,sizeof(vis));
	for(int i=1;i<=n;i++)
		cost[i]=dis[start][i];
	sum=0;
	vis[start]=1;
	for(int i=2;i<=n;i++)
	{
		int nm=0x3f3f3f,k=0;
		for(int j=1;j<=n;j++)
		{
			if(!vis[j] && cost[j]<nm)
			{
				nm=cost[j];
				k=j;
			}
		}
		vis[k]=true;
		sum+=nm;
		for(int j=1;j<=n;j++)
		{
			if(!vis[j] && dis[k][j]<cost[j])
				cost[j]=dis[k][j];
		}
	}
}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int ans=-1;
		memset(dis,0x3f3f3f,sizeof(dis));
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				scanf("%d",&dis[i][j]);
			}
		}

		for(int i=1;i<=n;i++)
			Prim(i);
		for(int i=1;i<=n;i++)
			ans=max(ans,cost[i]);
		printf("%d\n",ans);
	}
	return 0;
}

發佈了50 篇原創文章 · 獲贊 2 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章