PAT (Advanced Level) 1080. Graduate Admission (30) 模擬高考錄取,結構體排序

It is said that in 2013, there were about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade GE, and the interview grade GI. The final grade of an applicant is (GE + GI) / 2. The admission rules are:

  • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.
  • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade GE. If still tied, their ranks must be the same.
  • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.
  • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:

Each input file contains one test case. Each case starts with a line containing three positive integers: N (<=40,000), the total number of applicants; M (<=100), the total number of graduate schools; and K (<=5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's GE and GI, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M-1, and the applicants are numbered from 0 to N-1.

Output Specification:

For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:
11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4
Sample Output:
0 10
3
5 6 7
2 8

1 4
根據輸入記錄每個學生的id、各科分數、總分、所有志願。根據分數進行排序後,修正每個學生的排名。
記錄每個學校的錄取餘量和前一個錄取學生的排名(初始化爲0)。
按照學生的排名對所有學生進行遍歷。遍歷每一個學生的所有志願,若該學生的排名與所填報學校上一個錄取的學生一樣,不管學校餘量,直接錄取,學校餘量減1(可能減到負數)。若該學生的排名與學校上一個錄取的學生不一樣,則只在學校餘量大於0的時候錄取,同時學校餘量減1。
/*2015.7.30cyq*/
#include <iostream>
#include <vector>
#include <fstream>
#include <algorithm>
using namespace std;

//ifstream fin("case1.txt");
//#define cin fin

struct stu{
	int id;
	int GE;
	int GI;
	int sum;
	int rank;
	vector<int> choice;
};

bool cmp(const stu &a,const stu &b){
	if(a.sum>b.sum)
		return true;
	else if(a.sum==b.sum){
		if(a.GE>b.GE)
			return true;
	}
	return false;
}

int main(){
	int N,M,K;
	cin>>N>>M>>K;
	vector<int> school(M);//招生餘量
	for(int i=0;i<M;i++)
		cin>>school[i];

	vector<stu> stus(N);
	int x;
	for(int i=0;i<N;i++){
		stus[i].id=i;
		cin>>stus[i].GE; 
		cin>>stus[i].GI;
		stus[i].sum=stus[i].GE+stus[i].GI;
		for(int j=0;j<K;j++){
			cin>>x;
			stus[i].choice.push_back(x);
		}
	}

	sort(stus.begin(),stus.end(),cmp);
	int rk=1;
	stus[0].rank=1;
	for(int i=1;i<N;i++){//與前一個學生分數不完全一樣就更新排名
		if(stus[i].sum!=stus[i-1].sum)
			rk=i+1;
		else if(stus[i].GE!=stus[i-1].GE)
			rk=i+1;
		stus[i].rank=rk;
	}

	vector<vector<int> > result(M);
	vector<int> curRank(M,0);//curRank[i]表示學校i上一個接收學生的排名
	for(int i=0;i<N;i++){
		for(int j=0;j<K;j++){//檢測所有志願
			int apply=stus[i].choice[j];//申請的學校
			if(curRank[apply]==stus[i].rank){//與該學校上一個錄取的學生同分
				school[apply]--;//餘量減1
				result[apply].push_back(stus[i].id);
				break;
			}else{
				if(school[apply]>0){
					school[apply]--;
					curRank[apply]=stus[i].rank;
					result[apply].push_back(stus[i].id);
					break;
				}
			}
		}
	}

	for(int i=0;i<M;i++){
		if(!result[i].empty()){
			sort(result[i].begin(),result[i].end());
			cout<<result[i][0];
			for(auto it=result[i].begin()+1;it!=result[i].end();it++)
				cout<<" "<<*it;
		}
		cout<<endl;
	}

	return 0;
}


發佈了142 篇原創文章 · 獲贊 4 · 訪問量 9萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章