PAT (Advanced Level) 1083. List Grades (25) 結構體排序

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade's interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student's name and ID, separated by one space. If there is no student's grade in that interval, output "NONE" instead.

Sample Input 1:
4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100
Sample Output 1:
Mike CS991301
Mary EE990830
Joe Math990112
Sample Input 2:
2
Jean AA980920 60
Ann CS01 80
90 95
Sample Output 2:
NONE
/*2015.7.30cyq*/
#include <iostream>
#include <vector>
#include <algorithm>
#include <string>
#include <fstream>
using namespace std;

//ifstream fin("case1.txt");
//#define cin fin

struct stu{
	string name;
	string id;
	int score;
};

bool cmp(const stu &a,const stu &b){
	return a.score>b.score;
}
int main(){
	int N;
	cin>>N;
	vector<stu> stus(N);
	for(int i=0;i<N;i++){
		cin>>stus[i].name>>stus[i].id>>stus[i].score;
	}
	sort(stus.begin(),stus.end(),cmp);
	int low,high;
	cin>>low>>high;
	vector<stu> result;
	for(int i=0;i<N;i++){
		if(stus[i].score>=low&&stus[i].score<=high)
			result.push_back(stus[i]);
	}
	if(result.empty())
		cout<<"NONE";
	else{
		for(auto it=result.begin();it!=result.end();++it)
			cout<<(*it).name<<" "<<(*it).id<<endl;
	}
	return 0;
}

發佈了142 篇原創文章 · 獲贊 4 · 訪問量 9萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章