PAT (Advanced Level) 1085. Perfect Sequence (25) 貪心算法

Given a sequence of positive integers and another positive integer p. The sequence is said to be a "perfect sequence" if M <= m * p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (<= 105) is the number of integers in the sequence, and p (<= 109) is the parameter. In the second line there are N positive integers, each is no greater than 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:
10 8
2 3 20 4 5 1 6 7 8 9
Sample Output:
8
排序後使用貪心算法。
/*2015.7.30cyq*/
#include <iostream>
#include <vector>
#include <algorithm>
#include <fstream>
using namespace std;

//ifstream fin("case1.txt");
//#define cin fin

int main(){
	long long N,p;
	cin>>N>>p;
	vector<long long> ivec(N);
	for(int i=0;i<N;i++)
		cin>>ivec[i];

	sort(ivec.begin(),ivec.end());
	int low=0;
	int high=0;
	int len=0;
	while(1){
		while(high<N&&ivec[high]<=ivec[low]*p)
			high++;
		if(high-low>len)
			len=high-low;
		if(high==N)
			break;
		while(low<high&&ivec[low]*p<ivec[high])
			low++;
	}
	cout<<len;
	return 0;
}


發佈了142 篇原創文章 · 獲贊 4 · 訪問量 9萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章