EASY_ZJU_PAT_ADVANCED LEVEL_1027 任意進制轉換

1027. Colors in Mars (20)

時間限制
400 ms
內存限制
32000 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input
15 43 71
Sample Output
#123456

/******************************88

	@ NAME	:GAOMINQUAN
	@ MAIL	:[email protected]
	@ DATA	:2014 - 2- 23	
	@ HARD	:EASY **

*******************************/

#include<iostream>
#include<vector>
using namespace std;

char numToNum(int);
vector<char> changeRadix(int,int);
void formatPrint(vector<char> rNum);

int main(){
	int RGB[3];
	const int R = 13; //radix = 2
	
	for(int i = 0; i<3; i++){
		cin>>RGB[i];
	}
	
	cout<<"#";
	for(int colorI = 0; colorI < 3; colorI ++){
		formatPrint(changeRadix(RGB[colorI],R));
	}
	return 0;
}

void formatPrint(vector<char> rNum){
	if(rNum.size() == 2){
		for(int numI = rNum.size()-1; numI>=0; numI--){
			cout<<rNum[numI];
		}
	}else{
		cout<<"0"<<rNum[0];
	}
}
vector<char> changeRadix(int perviousNum,int R){
	vector<char> rNum;
	int num = perviousNum;
	if(num == 0){
		rNum.push_back('0');
	}else{
		while(num>0){
			int a  = num%R;
			num /= R;
			rNum.push_back(numToNum(a));
		}
	}
	return rNum;
}

char numToNum(int num){
	char newNum = '\0';
	if(num<10){
		newNum = '0' + num;
	}else{
		newNum = 'A' + num - 10;
	}
	return newNum;
}
	


發佈了40 篇原創文章 · 獲贊 3 · 訪問量 8萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章