2016SDAU編程練習二1002

Strange fuction 


Problem Description
Now, here is a fuction:<br>&nbsp;&nbsp;F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 &lt;= x &lt;=100)<br>Can you find the minimum value when x is between 0 and 100.
 


Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 


Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 


Sample Input
2<br>100<br>200 


Sample Output

-74.4291<br>-178.8534 

題意:求F(x)最小值

思路:求導就行了,注意精度

感想:二分三分都行,那個y唬人的,沒什麼用

AC代碼:

#include <cstdio>
#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<map>
#include<set>
#include<vector>
#include<iomanip>
using namespace std;
double y;
double q1(double x)
{
    return 6*x*x*x*x*x*x*x+8*x*x*x*x*x*x+7*x*x*x+5*x*x-y*x;
}
double q (double x)
{
    return 42*x*x*x*x*x*x+48*x*x*x*x*x+21*x*x+10*x-y;
}
int main()
{
    double x,h,l,mid;
    int N;
    cin>>N;
    while(N--)
    {


        cin>>y;
        l=0;
        h=100;
        while((h-l)>0.000000001)
        {
            mid=(h+l)/2;
            if(q(mid)>0) h=mid;
            else l=mid;
        }
        mid=q1(mid);
        printf("%.4f\n",mid);
    }


}


發佈了59 篇原創文章 · 獲贊 0 · 訪問量 7468
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章