2016SDAU編程練習二1003


Pie 

Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.<br><br>My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. <br><br>What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.<br>
 


Input
One line with a positive integer: the number of test cases. Then for each test case:<br>---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.<br>---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.<br>
 


Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
 


Sample Input
3<br>3 3<br>4 3 3<br>1 24<br>5<br>10 5<br>1 4 2 3 4 5 6 5 4 2<br> 


Sample Output
25.1327<br>3.1416<br>50.2655<br> 


Source

NWERC2006


題意:n個餅,f+1個人分,餅半徑不同,每個人拿到的必須完整,使我們分到的餅儘可能的大

思路:總體積除以總人數先求平均每人得到的,然後再二分,比較每人是否能達到這個理論值

感想:依舊精度

AC代碼:

#include <cstdio>
#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<map>
#include<set>
#include<vector>
#include<iomanip>
using namespace std;
double PI=acos(-1.0);
int main()
{
    double n,q,h,l,mid,ma,sum,r;
    double pie[100010];
    int N,i,num;
    cin>>N;
    while(N--)
    {


        cin>>n>>q;
        q++;
        sum=ma=0;
        for(i=0;i<n;i++)
        {
            cin>>r;
            pie[i]=r*PI*r;
            ma=max(ma,pie[i]);
            sum+=pie[i];
        }
        h=sum/q;
        l=0;
        while(h-l>0.00001)
        {
            num=0;mid=(h+l)/2;
            for(i=0;i<n;i++)
            {
                num+=(int)floor(pie[i]/mid);
            }
            if(num<q) h=mid;
            else l=mid;
        }
        printf("%.4f\n",l);
    }
     return 0;
}

 
發佈了59 篇原創文章 · 獲贊 0 · 訪問量 7471
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章