hdu3635 P - Dragon Balls

題目:

Five hundred years later, the number of dragon balls will increase unexpectedly, so it’s too difficult for Monkey King(WuKong) to gather all of the dragon balls together.

這裏寫圖片描述

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities’ dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

Input
The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

Sample Input
2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1

Sample Output
Case 1:
2 3 0
Case 2:
2 2 1
3 3 2

題目大意:

現在有n個龍珠分別放在n個城市,初始時他們都在自己標號相同的城市內,比如1號龍珠在1號城市中。2號在2號城市中,現在有兩種操作:
1:T A B 把A龍珠所在的城市的所有龍珠全部移動到B龍珠所在的城市.
2: Q A :詢問編號爲A的龍珠,要你輸出 龍珠A所在城市編號 龍珠A所在城市的龍珠數量 龍珠A的移動次數

思路:

帶權並查集,注意Get_f函數中的路徑壓縮的同時要改變移動次數.還有移動後要把移動出龍珠的城市的sum清零

代碼:

#include<map>
#include<string>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#include<bitset>
#include<climits>
#include<list>
#include<iomanip>
#include<stack>
#include<set>
const int maxn=123456;
using namespace std;
int T,n,q;
char op[3];
int a,b,flag,alone;
int f[maxn],cnt[maxn],sum[maxn];


void init()
{
    for(int i=0;i<=n;i++)
    {
        f[i]=i;
        sum[i]=1;
        cnt[i]=0;
    }
}

int Get_f(int v)
{
    if(f[v]==v)
        return v;
    int fa=Get_f(f[v]);
    cnt[v]+=cnt[f[v]];
    return f[v]=fa;
}

void Merge(int v,int u)
{
    int vv=Get_f(v);
    int uu=Get_f(u);
    if(vv!=uu)
    {
        f[vv]=uu;
        sum[uu]+=sum[vv];
        sum[vv]=0;
        cnt[vv]++;
    }
}


int main()
{
    scanf("%d",&T);
    int no=0;
    while(T--)
    {
        no++;
        printf("Case %d:\n",no);
        scanf("%d%d",&n,&q);
        init();
        while(q--)
        {
            scanf("%s%d",op,&a);
            if(op[0]=='T')
            {
                scanf("%d",&b);
                Merge(a,b);
            }
            else
            {
                int fa=Get_f(a);
                printf("%d %d %d\n",fa,sum[fa],cnt[a]);
            }
            //for(int i=1;i<=3;i++)
                //printf("f %d cnt %d sum %d\n",f[i],cnt[i],sum[i]);
        }
    }
    return 0;
}
發佈了90 篇原創文章 · 獲贊 3 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章