CSU-ACM2017暑期訓練10-並查集&&HASH F - Flying to the Mars HDU - 1800(字符串hash)

題目:


In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed . 
For example : 
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4; 
One method : 
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick. 
D could teach E;So D E are eligible to study on the same broomstick; 
Using this method , we need 2 broomsticks. 
Another method: 
D could teach A; So A D are eligible to study on the same broomstick. 
C could teach B; So B C are eligible to study on the same broomstick. 
E with no teacher or student are eligible to study on one broomstick. 
Using the method ,we need 3 broomsticks. 
…… 

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed. 
InputInput file contains multiple test cases. 
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000) 
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits); 
OutputFor each case, output the minimum number of broomsticks on a single line. Sample Input
4
10
20
30
04
5
2
3
4
3
4
Sample Output
1
2


          題意:有n個人學習騎掃把飛,每人有一個等級,水平高的人可以帶低的人,求需要的最少掃把。所以只要求最大重複元素即可。最少需要的掃把數量也就是這個最大重複元素個數。這裏由於每個人數字代表等級,而數字很大,與是用字符串hash。

代碼:

#include<map>
#include<string>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#include<bitset>
#include<climits>
#include<list>
#include<iomanip>
#include<stack>
#include<set>
const int maxn=7003;
using namespace std;

int Hash[maxn],Count[maxn];
int n,max_it;

int ELFhash(char *key)//常用字符串hash成數字函數
{
    unsigned long h = 0;
    unsigned long g;
    while(*key)
    {
        h=(h<<4)+*key++;
        g=h&0xf0000000L;
        if(g)
            h^=g>>24;
        h&=~g;
    }
    return h;
}

void hash_it(char *s)
{
    int k,t;
    while(*s=='0')
        s++;
    k=ELFhash(s);
    t=k%maxn;
    while(Hash[t]!=k&&Hash[t]!=-1)
        t=(t+10)%maxn;
    if(Hash[t]==-1)
    {
        Count[t]=1;
        Hash[t]=k;
    }
    //以上爲解決衝突
    else if(++Count[t]>max_it)
        max_it=Count[t];
}

int main()
{
    char s[111];
    while(scanf("%d",&n)!=EOF)
    {
        getchar();
        memset(Hash,-1,sizeof(Hash));
        max_it=1;
        while(n--)
        {
            gets(s);
            hash_it(s);
        }
        printf("%d\n",max_it);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章