2016 ccpc(長春) Sequence I (kmp)

Sequence I

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 958    Accepted Submission(s): 370


Problem Description
Mr. Frog has two sequences a1,a2,,an and b1,b2,,bm and a number p. He wants to know the number of positions q such that sequence b1,b2,,bm is exactly the sequence aq,aq+p,aq+2p,,aq+(m1)p where q+(m1)pn and q1.
 

Input
The first line contains only one integer T100, which indicates the number of test cases.

Each test case contains three lines.

The first line contains three space-separated integers 1n106,1m106 and 1p106.

The second line contains n integers a1,a2,,an(1ai109).

the third line contains m integers b1,b2,,bm(1bi109).
 

Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the number of valid q’s.
 

Sample Input
2 6 3 1 1 2 3 1 2 3 1 2 3 6 3 2 1 3 2 2 3 1 1 2 3
 

Sample Output
Case #1: 2 Case #2: 1
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:  5932 5931 5930 5929 5928

當時暴力過的,沒想過kmp,太菜了
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define maxx 1123456
int ne[1123456];
int s[maxx],t[maxx];
int p,sum;
void get_next(int l)
{
    int i=0,j=-1;
    ne[0]=-1;
    while(i<l)
    {
        if(j==-1 || t[i]==t[j])
        {
            i++;j++;ne[i]=j;
        }
        else
        {
            j=ne[j];
        }
    }
}
void kmp(int x,int ls,int lt)
{
    int i=x;
    int j=0;
    sum=0;
    while(i<ls)
    {
        if(j==-1 || s[i]==t[j])
        {
            i+=p;j++;
        }
        else
        {
            j=ne[j];
        }
        if(j==lt)
        {
            sum++;
            j=ne[j];
        }
    }

}
int main()
{
    int n,m,i;
    int ll;
    int tt;
    scanf("%d",&tt);
    for(ll=1;ll<=tt;ll++)
    {
        sum=0;
        scanf("%d%d%d",&n,&m,&p);
        for(i=0;i<n;i++)
        {
            scanf("%d",&s[i]);
        }
        for(i=0;i<m;i++)
        {
            scanf("%d",&t[i]);
        }
        get_next(m);
        int ans=0;
        for(i=1;i<=n;i++)
        {
            printf("%d ",ne[i]);
        }
        printf("\n");
        for(i=0;i<n&&i<p;i++)  //如果i大於p,就重複的找了
        {
            kmp(i,n,m);
            ans+=sum;
        }
        printf("Case #%d: %d\n",ll,ans);
    }

    return 0;
}



發佈了74 篇原創文章 · 獲贊 48 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章