POJ Area (pick)

    Area
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 6319   Accepted: 2771

Description

Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance robots patrolling the area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor抯 agent could find is the fact that the robots radio their movements unencrypted. Not being able to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight walls are used. Figure 1 shows the course of a robot around an example area. 

 
Figure 1: Example area. 

You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that simple formula for you, so your first task is to find the formula yourself. 

Input

The first line contains the number of scenarios. 
For each scenario, you are given the number m, 3 <= m < 100, of movements of the robot in the first line. The following m lines contain pairs 揹x dy�of integers, separated by a single blank, satisfying .-100 <= dx, dy <= 100 and (dx, dy) != (0, 0). Such a pair means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100 units. 

Output

The output for every scenario begins with a line containing 揝cenario #i:� where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area A rounded to one digit after the decimal point. Separate the three numbers by two single blanks. Terminate the output for the scenario with a blank line.

Sample Input

2
4
1 0
0 1
-1 0
0 -1
7
5 0
1 3
-2 2
-1 0
0 -3
-3 1
0 -3

Sample Output

Scenario #1:
0 4 1.0

Scenario #2:
12 16 19.0

Source


題意:給出一個點陣,上面的點連成了一個多邊形,求多邊形內部的點,多邊形邊界上的點,還有多邊形的面積

注意,給的數是相對上一個點移動距離,也就是這一個點和上一個點的向量


分析:1.pick定理,S=a/2+b-1   S是多邊形的面積,a是多邊形邊界上的點的數量,b是多邊形內點的數量

   2.任意一個多邊形的面積等於按順序求相鄰兩個點與原點組成的向量的叉積之和

   3.多邊形邊界上點個數等於gcd(x,y)  x是相鄰兩個點橫座標之差的絕對值,y是相鄰兩點縱座標之差的絕對值


#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>
using namespace std;
struct node
{
    int x,y;
}q[150];
int gcd(int a,int b)
{
    if(b==0)
        return a;
    else
        return gcd(b,a%b);
}
double area(node a,node b)
{
    return a.x*b.y-a.y*b.x;
}
int main()
{
    int n,m,i,j,t;
    int xx,yy;
    scanf("%d",&t);
    for(int ll=1;ll<=t;ll++)
    {
        int bd=0;
        double s=0;
        scanf("%d",&n);
        q[0].x=0;
        q[0].y=0;

        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&xx,&yy);
            bd+=gcd(abs(xx),abs(yy));
            q[i].x=q[i-1].x+xx;
            q[i].y=q[i-1].y+yy;
            s+=area(q[i],q[i-1]);
        }
        s=fabs(s);
        printf("Scenario #%d:\n",ll);
        printf("%d %d %.1f\n",(int(s)+2-bd)/2,bd,s/2);
        if(ll!=t)
        {
            printf("\n");
        }
    }
    return 0;
}



發佈了74 篇原創文章 · 獲贊 48 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章