【hdu2955】Robberies——01揹包

題目:

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18298    Accepted Submission(s): 6769


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output
2 4 6
 

Source

描述:給定搶銀行被抓的概率和銀行數,再分別給出每個銀行能搶到的錢數以及被抓的概率,求不被抓的情況下能搶到的最大錢數。

題解:首先能肯定的是肯定不能用概率做下標去dp錢數,那麼第一可以考慮dp[i]表示搶i百萬元錢時不被抓的概率,最後從sum開始找到第一個小於總的不被抓的概率的錢數i輸出。

代碼:

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <iostream>
using namespace std;
const int maxn = 105;
int  v[maxn];
double dp[10005];
int main()
{
	//freopen("input.txt", "r", stdin);
	int T, N;
	double P, w[maxn] = { 0.0 };
	scanf("%d", &T);
	while (T--)
	{
		scanf("%lf%d", &P, &N);
		int sum = 0;
		for (int i = 0; i < N; i++)
		{
			cin >> v[i] >> w[i];
			sum += v[i];
		}
		memset(dp, 0, sizeof(dp));
		dp[0] = 1;
		for (int i = 0; i < N; i++)
			for (int j = sum; j >= v[i]; j--)
				dp[j] = max(dp[j], dp[j - v[i]] * (1 - w[i]));
		for (int i = sum; i >= 0; i--)
			if (dp[i] > 1-P)
			{
				cout << i << endl;
				break;
			}
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章