Bone Collector(01揹包)

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?


Input The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone. Output One integer per line representing the maximum of the total value (this number will be less than 231).Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
14

題意:01揹包問題,求物品放入揹包能獲得的最大價值

題解:

F[i,j]:前i件物品放入容量爲v的揹包,故可以將問題轉化爲動態問題中的自底向上,也就是說考慮第i-1件的問題

考慮如果第i件物品放不放?
如果不放,則F[i-1,v]
如果放,則F[i-1,v-C[i]]

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
//物品價值 
int val[1005];
//物品體積 
int vol[1005]; 
int dp[1005][1005];
int main(){
	int t;
	cin>>t;
	while(t--){
		//揹包可容納的總數量 
		int n;
		//揹包可容納的總體積 
		int v;	
		cin>>n>>v;
		for(int i=1;i<=n;i++)
			cin>>val[i];
		for(int i=1;i<=n;i++)
			cin>>vol[i];
		//初始化
		for(int i=0;i<=n;i++)
			dp[i][0]=0;
		for(int j=0;j<=v;j++)
			dp[0][j]=0;
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++)
			for(int j=0;j<=v;j++)
				if(j<vol[i])
					dp[i][j]=dp[i-1][j];
				else
					dp[i][j]=max(dp[i-1][j],dp[i-1][j-vol[i]]+val[i]);
		cout<<dp[n][v]<<endl;
	}
	return 0;
} 


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章