HDU4961——Boring Sum(數論)

Boring Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 215    Accepted Submission(s): 103


Problem Description
Number theory is interesting, while this problem is boring.

Here is the problem. Given an integer sequence a1, a2, …, an, let S(i) = {j|1<=j<i, and aj is a multiple of ai}. If S(i) is not empty, let f(i) be the maximum integer in S(i); otherwise, f(i) = i. Now we define bi as af(i). Similarly, let T(i) = {j|i<j<=n, and aj is a multiple of ai}. If T(i) is not empty, let g(i) be the minimum integer in T(i); otherwise, g(i) = i. Now we define ci as ag(i). The boring sum of this sequence is defined as b1 * c1 + b2 * c2 + … + bn * cn.

Given an integer sequence, your task is to calculate its boring sum.
 

Input
The input contains multiple test cases.

Each case consists of two lines. The first line contains an integer n (1<=n<=100000). The second line contains n integers a1, a2, …, an (1<= ai<=100000).

The input is terminated by n = 0.
 

Output
Output the answer in a line.
 

Sample Input
5 1 4 2 3 9 0
 

Sample Output
136
Hint
In the sample, b1=1, c1=4, b2=4, c2=4, b3=4, c3=2, b4=3, c4=9, b5=9, c5=9, so b1 * c1 + b2 * c2 + … + b5 * c5 = 136.

題意:

給出數組a[i]

定義b[i]爲 a[i]左側第一個爲a[i]倍數的數字,如果沒有,則b[i]=a[i]。

定義c[i]爲 a[i]右側第一個爲a[i]倍數的數字,如果沒有,則c[i]=a[i]。

求∑(b[i]*c[i]) 

分析:

數組vis[i] 表示最新的是i的倍數的數字。

從左向右,如果vis[ a[i] ]>0 b[i]=vis[ a[i] ],否則b[i]=a[i],然後對於每一個a[i],枚舉他的約數並且更新數組vis。

再從右向左計算c[i]。

最後求出答案。

算法複雜度(n*sqrt(n))

#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#define INF 0x7fffffff
using namespace std;

const int N = 1e5 + 10;

int vis[N],a[N],b[N],c[N];

void update(int x)
{
    int k=sqrt(1.0*x);
    for(int i=1;i<=k;i++)
    {
        if(x%i) continue;

        vis[i]=vis[x/i]=x;
    }
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF&&n)
    {
        memset(vis,0,sizeof(vis));
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));

        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);

        for(int i=0;i<n;i++)
        {
            if(vis[a[i]]) b[i]=vis[a[i]];
            else b[i]=a[i];
            update(a[i]);
        }

        memset(vis,0,sizeof(vis));

        for(int i=n-1;i>=0;i--)
        {
            if(vis[a[i]]) c[i]=vis[a[i]];
            else c[i]=a[i];
            update(a[i]);
        }

        long long sum=0;
        for(int i=0;i<n;i++)
            sum+=1LL*c[i]*b[i];

        printf("%I64d\n",sum);
    }

    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章